Could not issue a Let's Encrypt SSL/TLS certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: figeecafe.nl

I ran this command: plesk, install Let’s Encrypt Cert

It produced this output:
Invalid response from https://acme-v02.api.letsencrypt.org/acme/order/50834563/904932969.
Details:
Type: urn:ietf:params:acme:error:malformed
Status: 404
Detail: No order for ID 904932969

My web server is (include version):
Plesk Onyx Version 17.8.11 Update #65

The operating system my web server runs on is (include version):
‪Debian 8.11‬

My hosting provider, if applicable, I run a dedicated is:
I run a dedicated server.

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Onyx Version 17.8.11 Update #65

I’ve clicked on renew from the plesk domain manager and got the error mentioned above. Can you please help me out? Might you need more information, I’d be glad to provide it.

Kind regards.

Hi @vascofmdc

that’s a plesk bug. Check

thank you very much for that link. it helped me solve the problem.
I’ve used this solution:

For Linux

  1. Connect to the Plesk server via SSH.
  2. Go to the /usr/local/psa/var/modules/letsencrypt/orders folder:2.1. Search for a json file that contains the ‘pending’ status:{“status”:“pending”,“location”:"https://acme-v02.api.letsencrypt.org/acme/order/xxxxxxxx/xxxxxxxxx",“subjects”:[“example.com”,“www.example.com”,“webmail.example.com”],“confirmationType”:“automatic”,“challenges”:[{“location”:"https://acme-v02.api.letsencrypt.org/acme/challenge/...2.2. Once found, remove it.
  3. Reissue a Let’s Encrypt certificate in Plesk at Domains > example.com > Let’s Encrypt .

I’ve posted it here for others to see what solved my problem.
thank you very much. have a great day.

2 Likes

Great, thanks for reporting back :+1:

Curious - that error, never seen before - now three users with the same problem. Looks like a new Plesk bug.

Of course, it’s the least I can do. I often see hit and runs, people that get their problem solved and don’t report back thanking the solution provider or telling others what they did to solve the problem, it annoyus the living s**t out of me.

don’t know if it’s a new bug, I have 21 domains on my server, all have Let’s Encrypt certs and only two that I had noticed had this problem. I’m keeping an eye out for more problems the next couple of days.

Thank you for pointing me into the right direction…

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.