Updated cert, website started serving default Ubuntu page


#1

I updated the cert on my website, literally that’s all I did, and the server crashed, when it came back up it was serving up the default Ubuntu page and not my wordpress site. Not sure what happened, anybody else seeing this? This being Amazon AWS, I created another instance and restored to it, all was well until I installed the cert, and I’m getting the same Ubuntu default page again.

My domain is: aves.org

I ran this command: sudo certbot certonly --manual --preferred-challenges dns

It produced this output: (all worked as it should)

My web server is (include version): Apache/2.4.29 (Unix)

The operating system my web server runs on is (include version): Ubuntu 16.04.3 LTS

My hosting provider, if applicable, is: Amazon AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi,

Can you please check your Apache ssl conf file?

(There might be an misconfig and your ssl wasn’t properly loaded)

Thank you


#3

Sorry it’s been a long day, can you tell me what I’m looking for. I did get ssl to load properly at one point, until the server decided to crash and when it came back up I had the default Ubuntu page.


#4

Hi,

Can you try to run
apache2ctl -S or apachectl -S and share the output?

Thank you


#5

VirtualHost configuration:
*:80 localhost (/opt/bitnami/apache2/conf/bitnami/bitnami.conf:8)
*:443 localhost (/opt/bitnami/apache2/conf/bitnami/bitnami.conf:43)
ServerRoot: "/opt/bitnami/apache2"
Main DocumentRoot: “/opt/bitnami/apache2/htdocs"
Main ErrorLog: “/opt/bitnami/apache2/logs/error_log"
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir=”/opt/bitnami/apache2/logs/” mechanism=default
Mutex proxy-balancer-shm: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex rewrite-map: using_defaults
PidFile: "/opt/bitnami/apache2/logs/httpd.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
Define: USE_PHP_FPM
User: name=“daemon” id=1 not_used
Group: name=“daemon” id=1 not_used


#6

Well, part of the mystery solved, on a reboot bitnami on ubuntu was refusing to start, said the port was already open, checked and apache2 was using port 80, I’d wound up with an /etc/init.d/apache2 that was starting before bitnami, thus hosing bitnami and displaying the default Ubuntu page when one browsed to the site. I disabled apache2 and now bitnami starts properly. I’m going to run through the all the steps again on a new virtual machine because I’m not sure when that script was dumped into /etc/init.d/.


#7

Did you install python-certbot-apache? That package pulls in Ubuntu’s apache package as a dependency, including the init script. If you’re using certbot certonly --manual then you don’t need the apache plugin so you could just install the certbot package instead.


#8

I did install python-certbot-apache on one of the test virtual machines, yes. Good to know that I don’t need to do that in the future. So on a new vm I would just do:

$ sudo apt-get update
$ sudo apt-get install software-properties-common
$ sudo add-apt-repository ppa:certbot/certbot
$ sudo apt-get update

right?


#9

Yes, and finally sudo apt-get install certbot


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.