Configuring Certbot Bitnami Apache Ubuntu AWS


#1

Whatever the level is below a noob, that’s what I am haha. I am testing out this AWS thing and managed to get a wordpress site up and going. I am just messing around with trying to get my site ssl certified and cant figure this out for the life of me. I have read through many other sites (including this one), and can’t find the answer. It seems that each person has some issue that is just different from mine. Any help is much appreciated. And please be patient with me :slight_smile:

My domain is: topnotchsolar.com

I ran this command: sudo certbot --apache (I ran this after I followed the install instructions here: https://certbot.eff.org/lets-encrypt/ubuntuxenial-apache)

It produced this output: https://pastebin.com/QULiE16A

My web server is (include version): Apache

The operating system my web server runs on is (include version): Ubuntu 16.04

My hosting provider, if applicable, is: none

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

Hi,

The output states that the issue is coming from Apache / httpd, do you happen to have other instance of web server running? (e.g. caddy? Nginx? Apache?)

Also, you Apache is not properly configtured… You could follow this guide to complete the apache configturation…

https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/CHAP_Tutorials.WebServerDB.CreateWebServer.html#CHAP_Tutorials.WebServerDB.CreateWebServer.Apache

Thank you


#3

Thanks for the quick reply.

I only have the one instance running. As far as I can tell, it’s Ubuntu 16.04 and Apache. Is there a way to verify those…?

I tried running sudo yum update -y like it says in the link you sent to me and I get this sudo: yum: command not found.


#4

Apologize… The correct tutorial for your version should be:

It’s not exactly for Amazon, but it’s similar…

Thank you


#5

I have this:

bitnami@ip-172-31-27-16:~$ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
Apache Full                ALLOW       Anywhere                  
Apache Full (v6)           ALLOW       Anywhere (v6)

Now what do I do? I tried the sudo certbot --apache command and it still gives the same error. Am I supposed to restart Apache somehow before trying to do the certbot again…?


#6

I just created a new instance in AWS so that I can start from scratch. What is the best route to go from here? Should I follow the instructions at https://certbot.eff.org/lets-encrypt/ubuntuxenial-apache?


#7

Not if you’re using Bitnami.

Bitnami includes a copy of Apache that doesn’t come from the Ubuntu repositories. If you follow the instructions on the Certbot website, that will install Certbot’s Apache plugin from the repository - and pull in Ubuntu’s Apache as a dependency. So you’ll end up with two copies of Apache, and Certbot will try to configure the wrong one.

I haven’t found a great tutorial for Bitnami but this is not too bad. The main problem with it is that it doesn’t retry properly if the renewal fails, so make sure to use a valid email address so you get the reminder notifications if your cert gets close to expiring. (I’m not familiar enough with the lego client to suggest how to improve the tutorial, but maybe someone else can).


#8

@jmorahan I will go through that link and see what I can do. I am so new to this whole ssh (and all the commands… holy moly), ssl, and aws stuff that this all may be above my skill level. I may try this out in a couple days and see what I can do, and what else I can mess up while I’m at it haha.

@stevenzhu Thanks for your help as well. I think I just got a little off-track with some other commands that I was running that may have messed it up.

Thanks guys!


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.