Website wont load after installing certbot on apache


#1

Hello I have installed certbot on ubuntu 16.04 running apache. I have been asked if I want to enable https and serve only https, and I answered yes, because my website is new and it only has 1 page, I thought it is right choice.
I am unable to access my website since. I tried to re-run installer in order to change settings so it would allow http website at least but it just would not work. Do I have to set up my website somehow? Can you point me to the right direction?

Help is very much appreciated, thank you.

My domain is: www.topshitmail.pw

I ran this command: sudo certbot --apache

It asked few general questions, like domain name. I put domain name without www/http.

My web server is (include version): Server version: Apache/2.4.18 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 16.04

My hosting provider, if applicable, is: Self hosted server

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Hi,

It seems that your port 443 ( https port) is either not open or blocked.

Can you check your port status?

Thank you


#3

Thank you stevenzhu. I forgot about ports completely. I thank you very much it is working well now.


#4

Hi,

It also seems that you only requested a certificate for topshitmail.pw, not www.topshitmail.pw

You might want to request one certificate containing both domains since visitors might get an “certificate name mismatch error”.

The command to run:
sudo certbot --apache -d topshitmail.pw -d www.topshitmail.pw

Thank you


#5

Thank you once again stevenzhu. I appreciate it very much. I sorted it out now.
I believe I will tweak it much more over time, it is my first project I am just getting familiar :slight_smile:
Have a nice day sir and all of you who help others, thank you


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.