Unable to renew

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: orateldiagnostics

I ran this command:
sudo certbot renew

It produced this output:

My web server is (include version):
Processing /etc/letsencrypt/renewal/orateldiagnostics.com.conf


Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for orateldiagnostics.com
http-01 challenge for www.orateldiagnostics.com
Cleaning up challenges
Attempting to renew cert (orateldiagnostics.com) from /etc/letsencrypt/renewal/orateldiagnostics.com.conf produced an unexpected error: Missing command line flag or config entry for this setting:
Select the webroot for www.orateldiagnostics.com:
Choices: [‘Enter a new webroot’, ‘/var/www/html/orateldiagnostics.com’]

(You can set this with the --webroot-path flag). Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/orateldiagnostics.com/fullchain.pem (failure)


All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/orateldiagnostics.com/fullchain.pem (failure)


1 renew failure(s), 0 parse failure(s)

The operating system my web server runs on is (include version):
ubuntu
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

certbot 0.31.0

2 posts were split to a new topic: How to extend duration of issue

It looks like you may have run into this Certbot bug: https://github.com/certbot/certbot/issues/7048

I think this should fix your issue for you:

sudo certbot renew --cert-name orateldiagnostics.com \
--webroot -w /var/www/html/orateldiagnostics.com
1 Like

The worked. Thanks for the help. Will this method need to be used for the next renew or will the renew command alone be enough.

Thanks!!

I’m not sure - maybe mark a calendar task for 60 days from now to check it. The issue on the bug tracker isn’t very clear about under what conditions this problem happens.

The bugfix is included in Certbot >=0.35.0, which isn’t yet available for Ubuntu 18.04.

I think the issue happens when Certbot reuses an authorization.

If that’s true, nothing should go wrong if you just renew every 2 months, since you’ll always be getting new authzs.

The dangerous actions would be --force-renewal, or --expand, or issuing duplicate certificates in other ways.

A post was split to a new topic: Issue renewing certificate

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.