Unable to renew expired cert?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:Dextr.Cloud

I ran this command:
bitnami@ip-172-16-2-250 : /opt/bitnami/apache2/conf $ sudo /opt/bitnami/letsencrypt/lego --tls --email=drvoip@drvoip.com --domains=dextr.cloud --path="/opt/bitnami/letsencrypt" renew --days 90

It produced this output: 2019/11/06 01:48:32 You have to pass an account (email address) to the program using --email or -m

My web server is (include version): apache2

The operating system my web server runs on is (include version): AWS Linux

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes i can log in

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
i am ssh into the bitnami stack. This was working but the cert expired and I am trying to renew it per the instructions dhttps://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): not using certbot should I?

Perhaps, since it has already expired, renew is no longer an option (?)
Try issuing it as new (again):

sudo /opt/bitnami/letsencrypt/lego \
--tls \
--email=drvoip@drvoip.com \
--domains=dextr.cloud \
--path="/opt/bitnami/letsencrypt" \
run

Thank you for all the help and recommendations, it is sincerely appreciated.
The wining strategy was:
Shut down Apache
Sudo Certbot renew
Restart
Worked so well, I am embarrassed at my ignorance!

1 Like