Renew expired certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:
sudo /opt/bitnami/ stop
sudo /opt/bitnami/letsencrypt/lego --tls --email="" --domains=“” --path="/opt/bitnami/letsencrypt" renew --days 90

It produced this output:
2020/08/05 19:00:25 Account is not registered. U
se ‘run’ to register a new account.

My web server is (include version):Apache/2.4.41 (Unix)

The operating system my web server runs on is (include version):Ubuntu 16.04.6 LTS

My hosting provider, if applicable, is:aws

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.31.0

Thank You.

1 Like

From what I can tell, lego’s renew command relies on you already having registered an ACME account.

Usually, lego does this automatically when you use the run command. Just like the example in Bitnami’s documentation (

sudo /opt/bitnami/letsencrypt/lego --tls --email="EMAIL-ADDRESS" --domains="DOMAIN" --domains="www.DOMAIN" --path="/opt/bitnami/letsencrypt" run 

What I can suggest is that you change renew --days 90 to run in your command, so that it will register a new account and setup all the files required for that.

After that, renew should work just fine.


Thank You so much for your help. It works now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.