Unable to install the certificate : raspberri pi3 Jeedom

Je peux lire des réponses en Anglais : oui

Mon nom de domaine est : antar.ddns.net

J’ai exécuté cette commande : ./certbot-auto --apache -d antar.ddns.net

Elle a produit cette sortie : Unable to install the certificate

Je peux me connecter à un shell root sur ma machine (oui ou non, ou je ne sais pas) : oui

Salut
Apres avoir il me semble fait le tour de toutes les verifs habituellement évoquées en cas de difficulté (pour info le cert a deja été installé avec succès sur une ancienne install), je viens tenter de soumettre mon erreur d’install car je ne la retrouve citée nulle part et donc je ne sais pas comment y reagir :

« Unable to install the certificate »

Un test dur SSL certficate checker me retourne : Certificate name mismatch

Une idee ?

Merci !

(en anglais pour que les autres puissent lire)

From Unable to install the certificate :

Can you post the result of apachectl -S here?

voici le resultat de la commande (en sudo)

VirtualHost configuration:
*:80 antar.ddns.net (/etc/apache2/sites-enabled/000-default.conf:1)
*:443 antar.ddns.net (/etc/apache2/sites-enabled/default-ssl.conf:2)
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/www/html/log/http.error”
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“www-data” id=33
Group: name=“www-data” id=33

Maybe @juergenauer will have an idea of what’s wrong?

Must i contact him directly by pm or other or your message will make him come here to answer ?

No need for PM, if he can, want and have time to help, hopefully he will answer :slightly_smiling_face:

Thank you, i’ll wait :+1:

post this file, please. use ``` before and ``` after.

1 Like

I’m not sure i understood what you meant, so i try like that :

<IfModule mod_ssl.c>
	<VirtualHost _default_:443>
		ServerAdmin webmaster@localhost

		DocumentRoot /var/www/html

		# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
		# error, crit, alert, emerg.
		# It is also possible to configure the loglevel for particular
		# modules, e.g.
		#LogLevel info ssl:warn

		ErrorLog ${APACHE_LOG_DIR}/error.log
		CustomLog ${APACHE_LOG_DIR}/access.log combined

		# For most configuration files from conf-available/, which are
		# enabled or disabled at a global level, it is possible to
		# include a line for only one particular virtual host. For example the
		# following line enables the CGI configuration for this host only
		# after it has been globally disabled with "a2disconf".
		#Include conf-available/serve-cgi-bin.conf

		#   SSL Engine Switch:
		#   Enable/Disable SSL for this virtual host.
		SSLEngine on

		#   A self-signed (snakeoil) certificate can be created by installing
		#   the ssl-cert package. See
		#   /usr/share/doc/apache2/README.Debian.gz for more info.
		#   If both key and certificate are stored in the same file, only the
		#   SSLCertificateFile directive is needed.
		SSLCertificateFile	/etc/ssl/certs/ssl-cert-snakeoil.pem
		SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

		#   Server Certificate Chain:
		#   Point SSLCertificateChainFile at a file containing the
		#   concatenation of PEM encoded CA certificates which form the
		#   certificate chain for the server certificate. Alternatively
		#   the referenced file can be the same as SSLCertificateFile
		#   when the CA certificates are directly appended to the server
		#   certificate for convinience.
		#SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt

		#   Certificate Authority (CA):
		#   Set the CA certificate verification path where to find CA
		#   certificates for client authentication or alternatively one
		#   huge file containing all of them (file must be PEM encoded)
		#   Note: Inside SSLCACertificatePath you need hash symlinks
		#		 to point to the certificate files. Use the provided
		#		 Makefile to update the hash symlinks after changes.
		#SSLCACertificatePath /etc/ssl/certs/
		#SSLCACertificateFile /etc/apache2/ssl.crt/ca-bundle.crt

		#   Certificate Revocation Lists (CRL):
		#   Set the CA revocation path where to find CA CRLs for client
		#   authentication or alternatively one huge file containing all
		#   of them (file must be PEM encoded)
		#   Note: Inside SSLCARevocationPath you need hash symlinks
		#		 to point to the certificate files. Use the provided
		#		 Makefile to update the hash symlinks after changes.
		#SSLCARevocationPath /etc/apache2/ssl.crl/
		#SSLCARevocationFile /etc/apache2/ssl.crl/ca-bundle.crl

		#   Client Authentication (Type):
		#   Client certificate verification type and depth.  Types are
		#   none, optional, require and optional_no_ca.  Depth is a
		#   number which specifies how deeply to verify the certificate
		#   issuer chain before deciding the certificate is not valid.
		#SSLVerifyClient require
		#SSLVerifyDepth  10

		#   SSL Engine Options:
		#   Set various options for the SSL engine.
		#   o FakeBasicAuth:
		#	 Translate the client X.509 into a Basic Authorisation.  This means that
		#	 the standard Auth/DBMAuth methods can be used for access control.  The
		#	 user name is the `one line' version of the client's X.509 certificate.
		#	 Note that no password is obtained from the user. Every entry in the user
		#	 file needs this password: `xxj31ZMTZzkVA'.
		#   o ExportCertData:
		#	 This exports two additional environment variables: SSL_CLIENT_CERT and
		#	 SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
		#	 server (always existing) and the client (only existing when client
		#	 authentication is used). This can be used to import the certificates
		#	 into CGI scripts.
		#   o StdEnvVars:
		#	 This exports the standard SSL/TLS related `SSL_*' environment variables.
		#	 Per default this exportation is switched off for performance reasons,
		#	 because the extraction step is an expensive operation and is usually
		#	 useless for serving static content. So one usually enables the
		#	 exportation for CGI and SSI requests only.
		#   o OptRenegotiate:
		#	 This enables optimized SSL connection renegotiation handling when SSL
		#	 directives are used in per-directory context.
		#SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
		<FilesMatch "\.(cgi|shtml|phtml|php)$">
				SSLOptions +StdEnvVars
		</FilesMatch>
		<Directory /usr/lib/cgi-bin>
				SSLOptions +StdEnvVars
		</Directory>

		#   SSL Protocol Adjustments:
		#   The safe and default but still SSL/TLS standard compliant shutdown
		#   approach is that mod_ssl sends the close notify alert but doesn't wait for
		#   the close notify alert from client. When you need a different shutdown
		#   approach you can use one of the following variables:
		#   o ssl-unclean-shutdown:
		#	 This forces an unclean shutdown when the connection is closed, i.e. no
		#	 SSL close notify alert is send or allowed to received.  This violates
		#	 the SSL/TLS standard but is needed for some brain-dead browsers. Use
		#	 this when you receive I/O errors because of the standard approach where
		#	 mod_ssl sends the close notify alert.
		#   o ssl-accurate-shutdown:
		#	 This forces an accurate shutdown when the connection is closed, i.e. a
		#	 SSL close notify alert is send and mod_ssl waits for the close notify
		#	 alert of the client. This is 100% SSL/TLS standard compliant, but in
		#	 practice often causes hanging connections with brain-dead browsers. Use
		#	 this only for browsers where you know that their SSL implementation
		#	 works correctly.
		#   Notice: Most problems of broken clients are also related to the HTTP
		#   keep-alive facility, so you usually additionally want to disable
		#   keep-alive for those clients, too. Use variable "nokeepalive" for this.
		#   Similarly, one has to force some clients to use HTTP/1.0 to workaround
		#   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
		#   "force-response-1.0" for this.
		# BrowserMatch "MSIE [2-6]" \
		#		nokeepalive ssl-unclean-shutdown \
		#		downgrade-1.0 force-response-1.0

	</VirtualHost>
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

```

Backup this file and delete it from that location, then run sudo certbot install --apache


or: Change these directives to point to files fullchain and key in `/etc/letsencrypt/live/__yourdomain__/` then do `systemctl reload apache2`

But NOTE: this will install your certificates but it does not let certbot reload apache on renewals.

`

sudo certbot install --apache`

= done

or:
SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem

SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

Don’t know what to do sorry … delete this files ?

systemctl reload apache2

: result :
root@raspberrypi:/etc/letsencrypt/live/antar.ddns.net# systemctl reload apache2
Warning: The unit file, source configuration file or drop-ins of apache2.service changed on disk. Run ‘systemctl daemon-reload’ to reload units.

no, let them stay. did you remove the /etc/apache2/sites-enabled/default-ssl.conf file?

Do what it tells you, then systemctl reload apache2 or systemctl restart apache2

yes i deleted the /etc/apache2/sites-enabled/default-ssl.conf file

i did that 3 commands like asked :
pi@raspberrypi:/etc/ssl sudo systemctl restart apache2 Warning: The unit file, source configuration file or drop-ins of apache2.service changed on disk. Run 'systemctl daemon-reload' to reload units. pi@raspberrypi:/etc/ssl sudo systemctl reload apache2
Warning: The unit file, source configuration file or drop-ins of apache2.service changed on disk. Run ‘systemctl daemon-reload’ to reload units.
pi@raspberrypi:/etc/ssl $ systemctl daemon-reload’

systemctl daemon-reload’
Unknown operation daemon-reload
systemctl daemon-reload.
pi@raspberrypi:/etc/ssl $

but pi@raspberrypi:/ $ certbot install --apache
-bash: certbot: command not found

eh, I should have noticed this.

use ./certbot-auto (in the proper directory) instead of certbot

i think i did the right way, please confirm if not, but no evolution of final result :

pi@raspberrypi:/etc $ ./certbot-auto --apache -d antar.ddns.net
Requesting to rerun ./certbot-auto with root privileges…
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Cert not yet due for renewal

You have an existing certificate that has exactly the same domains or certificate name you requested and isn’t close to expiry.
(ref: /etc/letsencrypt/renewal/antar.ddns.net.conf)

What would you like to do?


1: Attempt to reinstall this existing certificate
2: Renew & replace the cert (limit ~5 per 7 days)


Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2
Renewing an existing certificate
Could not reverse map the HTTPS VirtualHost to the original

IMPORTANT NOTES:

  • Unable to install the certificate
  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/antar.ddns.net/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/antar.ddns.net/privkey.pem
    Your cert will expire on 2020-06-09. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot-auto
    again with the “certonly” option. To non-interactively renew all
    of your certificates, run “certbot-auto renew”

tryied that (haven’t understood what you wanted me to do i think)

pi@raspberrypi:/etc $ ./certbot-auto install --apache
Requesting to rerun ./certbot-auto with root privileges…
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator None, Installer apache

Which certificate would you like to install?


1: antar.ddns.net


Press 1 [enter] to confirm the selection (press ‘c’ to cancel): 1
Could not reverse map the HTTPS VirtualHost to the original

IMPORTANT NOTES:

  • Unable to install the certificate

you just replaced a perfectly good certificate. don’t do that. :smiley:

automatic install should work, though… have you defined ServerName in the other virtualhost?
there should be a line saying

ServerName antar.ddns.net

if you see

ServerName localhost

, change it.

hosts file contain :

127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.1.1 raspberrypi
ServerName antar.ddns.net

I was talking about this file, not /etc/hosts.

(ps: use ```)

oops sorry :wink:

it contains : (command pi@raspberrypi:/etc/apache2/sites-enabled $ nano 000-default.conf
)

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog /var/www/html/log/http.error
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet `````