Unable to install the certificate

Hello,

I have created multiple domains (3) on my server and i have installed successfully lets encrypt certificate on two of them since yesterday.Today i created the third domain and moved the content inside and when i follow the same procedure to install the certificate i get the following error.
The other two domains with successful certificate installation, are also from noip

My domain is:mathimatikaab.ddns.net

I ran this command:sudo certbot --apache -d mathimatikaab.ddns.net

It produced this output:
Obtaining a new certificate
Could not reverse map the HTTPS VirtualHost to the original

IMPORTANT NOTES:

  • Unable to install the certificate
  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/mathimatikaab.ddns.net/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/mathimatikaab.ddns.net/privkey.pem
    Your cert will expire on 2020-06-21. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the “certonly” option. To non-interactively renew all of
    your certificates, run “certbot renew”

My web server is (include version):APACHE2 (LAMP)

The operating system my web server runs on is (include version):LINUX MINT 19

My hosting provider, if applicable, is:www.noip.com

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):0.31.0

Hi @melodyst,

This message means that Certbot had difficulty understanding your Apache configuration and could not successfully edit it in order to install the certificate.

Can you take a look at your Apache configuration and see if there’s something different about the setup of the virtual host for this 3rd domain in comparison to the virtual hosts for the other two domains?

1 Like

(one example of when this could happen is if you didn’t explicitly create a virtual host for this domain, and if you’re instead serving it using a “default” virtual host setup)

> glossacd.ddns.net
Address:  77.71.142.49

> glossaab.ddns.net
Address:  77.71.142.49

> mathimatikaab.ddns.net
*** resolver1-fs.opendns.com can't find mathimatikaab.ddns.net: Non-existent domain
*** 8.8.8.8 can't find mathimatikaab.ddns.net: Non-existent domain
*** 1.0.0.1 can't find mathimatikaab.ddns.net: Non-existent domain
*** 4.2.2.4 can't find mathimatikaab.ddns.net: Non-existent domain

Hello again ,

after triple checking everything ,discovered that it was a write permission that was missing
@rg305 yes this domain now doesn’t give results coz i tried once more to install the certificate after deleting the previous and i got a message for having reached the maximum allowed limit for certificate creation for a particular domain.
I have created a new one and i was able to install the cert fine

Thanks guys for your replies

1 Like