Unable to install the certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
bel.in.ua

I ran this command:
certbot run -d bel.in.ua

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for bel.in.ua
Waiting for verification…
Cleaning up challenges
Could not reverse map the HTTPS VirtualHost to the original

IMPORTANT NOTES:

  • Unable to install the certificate
  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/bel.in.ua/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/bel.in.ua/privkey.pem
    Your cert will expire on 2020-12-03. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the “certonly” option. To non-interactively renew all of
    your certificates, run “certbot renew”

My web server is (include version):
apache 4.15.0-45-generic

The operating system my web server runs on is (include version):
Ubuntu 18.04.4 LTS

My hosting provider, if applicable, is:
Scaleway

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):0.31.0

1 Like

Hi @trommo

looks like Certbot doesn’t understand your configuration.

What says

apachectl -S
3 Likes

root@trommo:~# apachectl -S
AH00558: apache2: Could not reliably determine the server’s fully qualified doma in name, using 127.0.0.1. Set the ‘ServerName’ directive globally to suppress th is message
VirtualHost configuration:
*:443 is a NameVirtualHost
default server aviatranslation.com (/etc/apache2/sites-enabled/aviatran slation.com-le-ssl.conf:2)
port 443 namevhost aviatranslation.com (/etc/apache2/sites-enabled/avia translation.com-le-ssl.conf:2)
port 443 namevhost cabare.co.ua (/etc/apache2/sites-enabled/cabare.co.u a-le-ssl.conf:2)
port 443 namevhost evrika.net.ua (/etc/apache2/sites-enabled/evrika.net .ua-le-ssl.conf:2)
port 443 namevhost tretyakov.co.ua (/etc/apache2/sites-enabled/tretyako v.co.ua-le-ssl.conf:2)
port 443 namevhost tvoydom.info (/etc/apache2/sites-enabled/tvoydom.inf o-le-ssl.conf:2)
port 443 namevhost u200.org (/etc/apache2/sites-enabled/u200.org-le-ssl .conf:2)
port 443 namevhost vostok-zapad.kharkov.ua (/etc/apache2/sites-enabled/ vostok-zapad.kharkov.ua-le-ssl.conf:2)
*:80 is a NameVirtualHost
default server 127.0.0.1 (/etc/apache2/sites-enabled/000-default.conf:1 )
port 80 namevhost 127.0.0.1 (/etc/apache2/sites-enabled/000-default.con f:1)
port 80 namevhost aviatranslation.com (/etc/apache2/sites-enabled/aviat ranslation.com.conf:1)
port 80 namevhost www.aviatranslation.com (/etc/apache2/sites-enabled/a viatranslation.com.conf:23)
port 80 namevhost batareyki.net (/etc/apache2/sites-enabled/batareyki.n et.conf:1)
port 80 namevhost www.batareyki.net (/etc/apache2/sites-enabled/batarey ki.net.conf:20)
port 80 namevhost bel.in.ua (/etc/apache2/sites-enabled/bel.in.ua.conf: 1)
port 80 namevhost www.bel.in.ua (/etc/apache2/sites-enabled/bel.in.ua.c onf:19)
port 80 namevhost cabare.co.ua (/etc/apache2/sites-enabled/cabare.co.ua .conf:1)
port 80 namevhost www.cabare.co.ua (/etc/apache2/sites-enabled/cabare.c o.ua.conf:23)
port 80 namevhost en.aviatranslation.com (/etc/apache2/sites-enabled/en .aviatranslation.com.conf:1)
port 80 namevhost www.en.aviatranslation.com (/etc/apache2/sites-enable d/en.aviatranslation.com.conf:20)
port 80 namevhost evrika.net.ua (/etc/apache2/sites-enabled/evrika.net. ua.conf:1)
port 80 namevhost www.evrika.net.ua (/etc/apache2/sites-enabled/evrika. net.ua.conf:23)
port 80 namevhost pma.tvoydom.info (/etc/apache2/sites-enabled/pma.conf :1)
port 80 namevhost www.pma.tvoydom.info (/etc/apache2/sites-enabled/pma. conf:19)
port 80 namevhost tretyakov.co.ua (/etc/apache2/sites-enabled/tretyakov .co.ua.conf:1)
port 80 namevhost www.tretyakov.co.ua (/etc/apache2/sites-enabled/trety akov.co.ua.conf:23)
port 80 namevhost tvoydom.info (/etc/apache2/sites-enabled/tvoydom.info .conf:1)
port 80 namevhost www.tvoydom.info (/etc/apache2/sites-enabled/tvoydom. info.conf:23)
port 80 namevhost u200.org (/etc/apache2/sites-enabled/u200.org.conf:1)
port 80 namevhost www.u200.org (/etc/apache2/sites-enabled/u200.org.con f:23)
port 80 namevhost vostok-zapad.kharkov.ua (/etc/apache2/sites-enabled/v ostok-zapad.kharkov.ua.conf:1)
port 80 namevhost www.vostok-zapad.kharkov.ua (/etc/apache2/sites-enabl ed/vostok-zapad.kharkov.ua.conf:23)
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“www-data” id=33
Group: name=“www-data” id=33
root@trommo:~#

1 Like

Looks like Certbot doesn’t like that:

You have one config file named bel.in.ua.conf with two different vHosts.

  • create one port 80 vHost with both domain names (remove both existing), then one certificate with both domain names (or)
  • may be split that file in two files (new www.bel.in.ua.conf), so every config file has only one vHost definition.

PS: Checked your domain manual. https has the aviatranslation.com certificate from your default vHost.

So you have an additional option:

Use that port 443 vHost definition as template and create the port 443 vHost of bel.in.ua manual. Then it’s not required that Certbot creates the vHost.

3 Likes

Thank you very much - I’ve created conf-file manually. It works!

4 Likes

Yep, now you have a working https :+1:

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.