Unable to get certificate: HestiaCP

Hi all,
I registered my domain, installed HestiaCP on Ububtu 22.04 and I am having a problem to get the certificate. I already did this in past and had no problem. Looking at check-your-website.server-daten.de I can't really tell what the problem is.

My domain is: hcp.hx7.eu
I ran this command: from Hestia CP

It produced this output: Error: Let's Encrypt validation status 400 (hcp.hx7.eu). Details: 403:" Invalid response from http://hcp.hx7.eu/.well-known/acme-challenge/rJY8jq3alrTwIRUit7yHQ7H-qoK6oiPcV_6HKYRhtr0: 404"


My web server is (include version): nginx/1.23.2

The operating system my web server runs on is (include version): Ubuntu 22.04.1 LTS

I can login to a root shell on my machine: yes

I'm using a control panel to manage my site: HestiaCP v1.6.5

DNS records:

name / TTL / type / data	 
 / 300 / A /	 
 / 300 / CAA / 0 issue "letsencrypt.org"	 
 / 300 / CAA / 0 iodef "mailto:himi@centrum.cz"	 
* / 300 / A /	 
hcp / 300	/ A /	
mail	/ 300 / A /	 
mail	/ 300 / MX / 0 mail.hx7.eu	 
www / 300 / A /


I also tried to add following DNS records with token:


but the result is the same. Do I need to add _acme-challenge with token to my DNS records? If so, how do I know which token HestiaCP uses when requesting SSL Let's encrypt certificate? For now I removed it as there was no change.

reading through various forums, I also tried letsdebug.net with following result:

All OK!
No issues were found with hcp.hx7.eu. If you are having problems with creating an SSL certificate, please visit the Let's Encrypt Community forums and post a question there.

I created another subdomain in Hestia CP, this time under a user (not admin as for hcp.hx7.eu), and tried to generate SSL certificate. And it worked! So I wonder why it does not work for admin :thinking:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.