Unable to generate certificate for saksham.co.in

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: saksham.co.in

I ran this command: ./certbot-auto certonly --manual --preferred-challenges=dns --email ankitdmehta@gmail.com --agree-tos -d saksham.co.in

It produced this output:
Waiting for verification...
Challenge failed for domain saksham.co.in
dns-01 challenge for saksham.co.in
Cleaning up challenges
Some challenges have failed.


  • The following errors were reported by the server:

    Domain: saksham.co.in
    Type: dns
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.saksham.co.in - check that a DNS record exists for
    this domain

My web server is (include version): nginx

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): no

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): yes.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi @Pankti

there is a check of your domain, ~~one hour old - https://check-your-website.server-daten.de/?q=saksham.co.in#txt

There is no TXT record visible.

  • Start Certbot again
  • Create the required TXT entry
  • Then start the online check again to see, if the TXT RR is visible (and not one of the wrong)
  • After checking / correcting your TXT entry, confirm Certbot
1 Like

Two things:


Hey, thank you for your quick response.

You are right. I need wildcard SSL, in fact a certificate just for the subdomain mailer.saksham.co.in. I do not have access to the server and hence the only way out is dns-01 challenge. I tried several times to add the txt record but it keeps failing with error "check that a DNS record exists for
this domain".

Thanks again for all assistance.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.