DNS problem: NXDOMAIN looking up TXT for _acme-challenge

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:womensescapes.com

I ran this command:
sudo comcertbot certonly --manual --preferred-challenges dns --server https://acme-v02.api.letsencrypt.org/directory --manual-public-ip-logging-ok -d ‘*.womensescapes.com’ -d womensescapes.com

It produced this output:
Please deploy a DNS TXT record under the name
_acme-challenge.womensescapes.com with the following value:

YolGY4poGa2_1KNUqMqilD8H-oENmpZLEb5yRJxVETw

My web server is (include version):
AWS

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

DNS Record added to my godaddy

1 Like

Hi @mikesmith91

you have created the wrong entry. And you have created only one entry:

Two entries are required.

See the screenshot - https://check-your-website.server-daten.de/?q=womensescapes.com#txt

and compare it with a correct entry:

Your menu adds the domain name, so create only entries with _acme-challenge. And two entries with the same name are required, one with the wildcard value, one with the main domain value.

Start new, create the two entries, recheck your domain with the online tool. Two “looks good” should be visible.

1 Like

Thank You It works now

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.