Ubuntu 16.4/Apache 2.4 timeout during connect (likely firewall problem)


#1

I setup a Ubuntu 16.4 and Apache and tried using certbot and tried different way to obtain certs but always come up with:

Timeout during connect (likely firewall problem)

If I try with “-debug-challenges”, and try to connect to those it usually take < 100ms. What are some options I can try?


#2

Can you provide more information?

Can you connect from another computer? Another network? Another ISP? Another country? If the hostname has an IPv6 address in the DNS, is it correct and working? Could there be a firewall or networking issue?


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#3

Nevermind. Looks like my ISP, Optimum, blocked the ports when they replaced my cable modem. Now I’m trying to get them to open them again.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.