Trying to renew cert on nginx but getting "Problem binding to port 443: Could not bind to IPv4 or IPv6"


#1

I’m trying to renew my cert for my personal site, but it seems to be failing (issue with port 443).

Thanks in advance for your help!

My domain is: www.retrosockets.io

I ran this command:

/opt/letsencrypt/certbot-auto certonly --standalone

I’ve also tried:

/opt/letsencrypt/certbot-auto-renew

And got the same output.

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Please enter in your domain name(s) (comma and/or space separated)  (Enter 'c'
to cancel):www.retrosockets.io retrosockets.io
Cert is due for renewal, auto-renewing...
Renewing an existing certificate
Performing the following challenges:
tls-sni-01 challenge for www.retrosockets.io
tls-sni-01 challenge for retrosockets.io
Cleaning up challenges
Problem binding to port 443: Could not bind to IPv4 or IPv6.

My web server is (include version): nginx/1.10.0 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 16.04.1 LTS

My hosting provider, if applicable, is:
Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no


#2

I think I resolved this. Had to shut down the nginx server, run the command, and then restart. Not my favorite solution, but it worked.


#3

This happened because you used --standalone. The purpose of that option is to launch a temporary webserver because you don’t have one running.

Next time use the --webroot method, and you’ll be able to use your already running nginx server.


#4

That’s very helpful! Thank you!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.