Trying to add Certificate producing error 400

My domain is:

I ran this command: Trying to add the certificate

It produced this output: Detail: Invalid response from


Type: urn:ietf:params:acme:error:dns

Status: 400

Detail: DNS problem: NXDOMAIN looking up TXT for - check that a DNS record exists for this domain

My web server is (include version):

The operating system my web server runs on is (include version): Plesk (i guess?)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): i dont know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): yes,

I have like 0 clue about this, i just tryed to add the certificate and i got that error

Please elaborate, what does this entail in your scenario?


It depends on how your DNS is set up. See the following Plesk article:


You tried to use DNS validation. To achieve DNS validation you need to create a very specific TXT record in your DNS with a certain value, how you know what that value is depend on what tool you use to get the certificate. Currently looking up returns a CNAME record to but if you were really using DNS validation that would return a TXT record with a value.

Try using http validation instead?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.