Too many failed authentications using certbot --nginx

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www,xuuki.xyz

I ran this command: cerbot --nginx

It produced this output: An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/

My web server is (include version): not sure how to answer this

The operating system my web server runs on is (include version): Debian

My hosting provider, if applicable, is: Vultr and Epik

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Cerbot 0.31.0

Thanks you very much in advance. This will hopefully help me learn more about setting up a webserver

1 Like

I hope to give some helpful info here. This is the output of certbot --nginx: Which names would you like to activate HTTPS for?


1: xuuki.xyz
2: mail.xuuki.xyz
3: www.mail.xuuki.xyz
4: www.xuuki.xyz


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1 4
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.xuuki.xyz
nginx: [warn] conflicting server name “xuuki.xyz” on 0.0.0.0:80, ignored
nginx: [warn] conflicting server name “www.xuuki.xyz” on 0.0.0.0:80, ignored
nginx: [warn] conflicting server name “xuuki.xyz” on [::]:80, ignored
nginx: [warn] conflicting server name “www.xuuki.xyz” on [::]:80, ignored
Waiting for verification…
Cleaning up challenges
nginx: [warn] conflicting server name “xuuki.xyz” on 0.0.0.0:80, ignored
nginx: [warn] conflicting server name “www.xuuki.xyz” on 0.0.0.0:80, ignored
nginx: [warn] conflicting server name “xuuki.xyz” on [::]:80, ignored
nginx: [warn] conflicting server name “www.xuuki.xyz” on [::]:80, ignored
Failed authorization procedure. www.xuuki.xyz (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.xuuki.xyz/.well-known/acme-challenge/09Ug9LHNYz9cojzjPHK1PTPvV2YKtQQy6adsvIpw-vc [2001:19f0:7400:87c8:5400:2ff:fee1:67e6]: “\r\n404 Not Found\r\n<body bgcolor=“white”>\r\n

404 Not Found

\r\n

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.xuuki.xyz
    Type: unauthorized
    Detail: Invalid response from
    http://www.xuuki.xyz/.well-known/acme-challenge/09Ug9LHNYz9cojzjPHK1PTPvV2YKtQQy6adsvIpw-vc
    [2001:19f0:7400:87c8:5400:2ff:fee1:67e6]:
    “\r\n404 Not Found\r\n<body
    bgcolor=“white”>\r\n

    404 Not
    Found

    \r\n

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.

1 Like

Hi @vyvyanmar

there

is your job. You have multiple definitions, that’s always wrong. Merge all duplicated definitions.

2 Likes

Thanks @JuergenAuer. May you show me how to merge all duplicated definitions?
I wasnt sure where nginx was storing these definitions to see the dupications I have to merge. I’ve checked the nginx man page for anything about merging or duplicates but I havent found the correct command yet … Ah or its possibly because the default file is in /etc/nginx/sites-enabled, perhaps getting rid of that should work. :slight_smile:

1 Like

…which is has thank you very much for your help! :smiley: This is my first website online now woohoo!

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.