Too many certificates

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --nginx

It produced this output: "too many certificate....5 certificate in 164 hours..."

My web server is (include version): nginx

The operating system my web server runs on is (include version):Linux instance-1 5.10.0-21-cloud-amd64 #1 SMP Debian 5.10.162-1 (2023-01-21) x86_64

My hosting provider, if applicable, is: google compute engine

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): ssh terminal

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.3.0

Please help me to fix this matter.... this is the company website.... serious error happened and I had to deploy yesterday... I thought everything was okay but finally I got several problem, "not allowed header...", sometimes gunicorn problem that I could not fix... that's why I was panic and tried all up. Google compute engine is okay now as long as I can received the certificate from "Let's Encript".

What help do you need?
You should have at least one working certificate.
certbot certificates


All the recent certificates lack the "www" name [seen in the previous certs]: |


All the instance I failed to deploy was destroyed. so I got only one instance at Google

Let me check at google now Thanks a lot

This is the message I got "The following error was encountered:
[Errno 13] Permission denied: '/var/log/letsencrypt/.certbot.lock'
Either run as root, or set --config-dir, --work-dir, and --logs-dir to writeable paths.
Ask for help or search for solutions at See the logfile /tmp/certbot-log-fwzbo3sd/log or re-run Certbot with -v for more details."

Oh my goodness... I can see how much I was panic to deploy website... please help me to fix this problem... do I need to re-run Certbot with -v ?

The last one I am about to deploy the website... I did put 'www' one. I just checked 'nginx' now.

Did you use sudo certbot ... when you got the permission denied?


Yes it was denied in few minutes. I did sudo certbot --nginx -v

Do you want me to try again?

Is there a .lock file in that folder? You might need to delete that if it was leftover from a prior killed certbot.

But, I can't reach your domain right now so you should fix that first

curl -i -m8
HTTP/1.1 400 Bad Request
Server: nginx/1.18.0
<!DOCTYPE html><html lang="en"><head><title>Bad Request (400)</title>

curl -i -m8
curl: (28) Connection timed out after 8001 milliseconds

Ok Thanks a lot. When I come back, I will try do it myself

Once again, I do much appreciate your help

1 Like

I looked /bar/log/letsencrypt/ but there is no .lock file in there. Is that the right place?

I forgot one thing to tell you. When I command this, 'sudo certbot --nginx', I got this message "sudo: certbot: command not found." so I did try this "sudo snap certbot --nginx". but still denied.

I have still that problem... my company website is still dead. The error message said I can get after 2pm today.

How is that possible?
Are you on the right system?
Did you delete/uninstall certbot?


I installed in a different way " sudo apt-get install certbot python3-certbot-nginx , then now I can use 'sudo certbot --nginx' but still same problem.

The thing you told me to delete, I could not find in the directory. I can see the certbot folder home directiory. Do you want me to delete the folder?

Do you want me to uninstall certbot? or delete it ? I am too scared to just delete it. Is there any certain way to uninstall, I mean proper way to do it..

I did uninstall by following command, "sudo apt-get remove certbot"
After this, " sudo apt-get autoremove

But the problem is that those following file I can not remove


They are all 'read only file system'

Now what shall I do?