The executable python2 (from --python=python2) does not exist


#1

I get the following error while trying to get a certificate:

Creating virtual environment...
The executable python2 (from --python=python2) does not exist

While running VERBOSE=1 ./letsencrypt-auto --server "https://acme-v01.api.letsencrypt.org/directory" --agree-dev-preview auth -d example.com -d www.example.com.

Passing --python=python doesn’t help. Should I just symlink python2 to python?

Without VERBOSE=1 there’s no helpful message at all.


#2

Hi @kelunik. May I ask what operating system you’re running on? This is a known issue on Debian squeeze (see #1078).

In my opinion, you have three options until the issue is resolved:

  1. Symlink python2 to python as you suggested.
  2. Edit letsencrypt-auto to use --python python instead of --python python2. As of writing this post, that needed edited are 64 and 66.
  3. If you feel comfortable hacking on the script, send us a pull request! Modify letsencrypt-auto to detect when python2 isn’t available and fallback to python.

I’m sorry letsencrypt-auto didn’t work for you, but any of these three approaches should fix the problem.


#3

Indeed, it’s an old Debian squeeze server. Symlinking resolved the issue, but another one appeared. I’m not sure if it’s connected to the python version (2.6):

Collecting ConfigArgParse (from letsencrypt)
  Using cached ConfigArgParse-0.9.3.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 20, in <module>
      File "/tmp/pip-build-j7REr4/ConfigArgParse/setup.py", line 1, in <module>
        import configargparse
      File "configargparse.py", line 16
        ACTION_TYPES_THAT_DONT_NEED_A_VALUE = {argparse._StoreTrueAction,
                                                                        ^
    SyntaxError: invalid syntax
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-j7REr4/ConfigArgParse

#4

:frowning: that’s also a known problem (see #1046). There are some workarounds suggested there that might help you. Python 2.6 support was recently added back to the project and there are a few kinks that still have to be worked out.


[SOLVED]Error installing the client CentOS 6.7
#5

Fine, thanks! Unfortunately no python experience.