SSL Renewal ISSUE


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

Please check my renewal notification email http://prntscr.com/ljf6p3 . my register email ID is :zack@appsbizz.com.au

My domain is: ausmotogear.com.au

I ran this command: check screenshot: http://prntscr.com/ljf5x0
/opt/bitnami/mysql/scripts/ctl.sh : mysql stopped
bitnami@ip-172-26-12-99:~$ sudo lego --email=“zack@appsbizz.com.au” --domains=“ausmotogear.com.au” --path="/etc/lego" renew

It produced this output:
2018/11/17 05:19:25 Account zack@appsbizz.com.au is not registered. Use ‘run’ to register a new account.

My web server is (include version):
AWS lightsail using Bitnami

The operating system my web server runs on is (include version):
Linux
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
AWS lightsail terminal

For reference discussion with Bitnami team please go through https://community.bitnami.com/t/lets-encrypt-installation-error/60015/13 (Check my Name Replies: Ansarul)

Auto-renewal also not working please check my autorenwal commands

i have added the auto renewal command please check snapshot: http://prntscr.com/ljf42d
after that add command : sudo chmod +x /etc/lego/renew-certificate.sh

Please help how can i resolve my issue


#2

Hi,

As the first screenshot said, you must register a account with Lego (with this Let’s Encrypt client) first…

Have you tried to run sudo lego run?

Thank you


#3

Hi Stevenzhu
Thanks for your prompt reply

I have some query please check below

I know they are asking registration but i have already registered account then install the ssl why asking for registration. but i am getting notification in my register email. how it possible get notify without registration

if i going to proceed to registration with same email then its may regenerate certificate right?


#4

Sorry but I’m not sure why it’s asking you for a registration again… I could see that at least your email was registered before… (You might need to ask the support community of this script for more information)

If you proceed with registration, you surely will be able to generate certificates (at least passed these warnings about it)

Thank you


#5

Did you use lego before? And did you use it on this same server?


#6

Yes @schoen
I was run when i installed the SSL and even i am getting notification by email

but i dont know why responding not register the email please help me how i renew the ssl only 9 days left to expire


#7

Did you maybe run lego from a different user account? Do you have the original lego command line?


#8

Hi @schoen

I dont have original lego

But I am sure i register with this email and even getting notification as well from letsencrypt, can you check in you system for this my domain:ausmotogear.com.au register email: zack@appsbizz.com.au or else can you help me which email register with the domain: ausmotogear.com.au

or

if you have any alternate solution please help me


#10

I believe that the message that you’re seeing Account zack@appsbizz.com.au is not registered. Use ‘run’ to register a new account is not from the Let’s Encrypt CA, but from lego. In this case lego is saying that it can’t find the file on your server containing your account credentials. That why I’m focusing on the question of which user account you used when running lego.

I agree that there is almost certainly an account with this e-mail address registered with Let’s Encrypt. So the error message from lego is misleading; it should probably say “can’t find account credentials” instead of “account not registered”.

It would be helpful if someone more familiar with lego could suggest where the credentials are supposed to be stored, since I’m not very familiar with this client application.


#11

It’s also worth pointing out that you don’t have to use the same account to renew the certificate. Let’s Encrypt accounts are not very important for most purposes and you’re allowed to create many of them. So if you can’t figure out where the credentials went, you can definitely create a new account and use the new account to request a certificate. Let’s Encrypt won’t refuse to issue the new certificate just because the previous certificate was obtained using a different account.


#13

A post was split to a new topic: Renewing non-expired certificate