SSL Problem on Wordpress

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I have Problem On flexible SSL
My Wordpress is Looping Redirect (too many redirect)

I ran this command:

It produced this output:

My web server is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
cpanel / wordpress

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


Welcome to the Let's Encrypt Community, Hamed :slightly_smiling_face:

The Site Address (URL) and WordPress Address (URL) in your WordPress settings probably both begin with http instead of https. When that is combined with Force HTTPS Redirection in your cPanel settings, you get a circular redirect.

Here are the official instructions for both:


I just checked you site and it appears that the site is working ok

not much in the way of content so I assume it's a new site

your ISP server is showing a unused domain for sale.

Thanks Dear, my problem has been fixed with force redirect on https

thanks all other pay attention to my topic


You are quite welcome. :blush:

Your website has "mixed content" (content served over http instead of https), so many browsers will indicate that it is insecure despite having a working certificate. You can use the website below to find the http references in order to change them to https.

1 Like

When checking your site with, I noticed that your website now does not redirect at all from http to https. You probably want to use the instructions I gave you to change the two WordPress settings I mentioned before.

1 Like

There is a WP plugin: Better Search Replace, use to search for http:// and replace with https:// which will fix the mixed content flagging google cannot figure out

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.