SSL Not Added into Website

My domain is:

I ran this command:

It produced this output: Normal Response

My web server is (include version): Digital Ocean: Ubuntu ^20

The operating system my web server runs on is (include version): Linux

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Sorta.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 2.3.0

For some reason, when I run the general commands to add an SSL, it won't add the SSL when the console said it was created.

Can you show the Certbot command you used. You say you have V2.3.0

sudo certbot --manual --preferred-challenges dns certonly -d
An unexpected error occurred:
Error creating new order :: too many certificates (5) already issued for this exact set of domains in the last 168 hours:, retry after 2023-02-20T11:46:59Z: see

How can I use the certificate than?

You need to configure your web service to use one of the 5 certs you got.

You did not mention what kind of web server you were using otherwise I could give some further advice


Digital Ocean is hosting it.

How can i configure it to do so?
Should I use cloudflare?

Maybe start by asking them for assistance. This isn't a general "how to" configure a server forum. You haven't even said what you are running and I can't reach your domain on port 80 or 443.


It is on port 80.

Nothing is responding on port 80. You should contact your hosting service.

Also, see Let's Debug test site (link here)


When you run this command, the certonly part means that it will only obtain the cert (which you've done successfully, five times now), but not configure your web server (or other software) to use that cert. And since "Digital Ocean: Ubuntu ^20" isn't a web server (it's a VPS provider and a name and version of a Linux distribution), we can't give you any further pointers on where to even start looking for instructions on how to configure it.

When you figure out what web server software you're running, consult its documentation for information on how to configure it to use one of the five certs you've already obtained.

Digital Ocean mainly provides VPS hosting, so OP is pretty much on his own here.


Well, we could assist with the certificates part.. But currently, there's no IP address for (nor the www subdomain) in the DNS tree. So having a working HTTP(S) server without an IP address is a problem in the first place.

Next, we're indeed seriously lacking information here, as "Ubuntu" (as stated in the OP) is not a webserver, but a Linux distribution indeed. So it would be helpful for OP to tell us the actual webserver used too.


Interesting; there was a few hours ago. Seems like a step backward.

@s1imdev, be aware that if you're considering just destroying the instance and starting over, this will lose the certificates you've created and you won't be able to make any more for a week. That is not the path to success here.

We could, but OP already has that--five times over.


I meant the installing part :wink: E.g., help with finding the right keywords to get a tutorial on how to install a cert into webserver X.


I loaded Apache, but the thing is I tried w/ both apache option & the other

It is up also.

What shows?:
certbot certificates


Fair point but at the start they did not know what web server they were running, thought port 80 was open when it was not, and wondered if Cloudflare could help them.

To me that sounded like they didn't understand the products they purchased and so I suggested contacting that provider. If nothing else, on Digital Ocean's home page there is a link for their community which could help them get their basic server setup.

They now have Cloudflare CDN and CF got a cert from Google Trust Services. Their home page gets a 403 so may not have viable server yet. And, I don't see any other certs in the log so they may be using Flex mode. But, these decisions are best resolved at Cloudflare's community :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.