SSL for most important domain is not working

Hi, I own 3 domains and host them via allinkl.com - but actually I just run one of them and built a website, which is

nicoyoga.de

I ordered the ssl certificate of let`s encrypt via allinkl.com today
My account says, that all 3 of them are activated:

Ihre zur Zeit aktiven SSL-Zertifikate:
|nicoyoga.de|[Let’s Encrypt]|
|nicolegebauer.de|[Let’s Encrypt]|
|nicoshakti.de|[Let’s Encrypt]|

But when I open my nicoyoga.de site, there still is this warning, which says, that it is not safe. If I open the other two, itshows the under construction text - but it does not show this warning...

Can you please help me?
Thank You,
Nicole

Welcome to the community @Nicole

You may need to restart your browser to clear its certificate cache. Or, make sure you are using HTTPS to connect to that domain.

But, most likely the problem is because that one domain is not redirecting from HTTP to HTTPS.

Your cert is working properly for nicoyoga.de and www.nicoyoga.de but if you don't use HTTPS:// in the URL you will be using the HTTP connection which is not secure. Some browsers use https automatically but not all.

Your other domain redirects properly

See nicoyoga redirects to HTTP and your www name then gives 200 OK response

curl -I nicoyoga.de
HTTP/1.1 301 Moved Permanently
Server: Apache
X-Redirect-By: WordPress
Location: http://www.nicoyoga.de/

curl -I http://www.nicoyoga.de
HTTP/1.1 200 OK

Using HTTPS it also works

curl -I https://www.nicoyoga.de
HTTP/2 200
server: Apache

But, see this domain redirects HTTP to HTTPS like it should

curl -I http://allinkl.com
HTTP/1.1 301 Moved Permanently
Server: Apache
Location: https://all-inkl.com/
3 Likes

I see a dash in the redirected address :eyes:

3 Likes

Good eye. That's another error but at least it had the HTTPS part right :slight_smile:

3 Likes

Thank you so much! I managed to change settings to https - and now it worked!

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.