Site showing SSL after hitting refresh


#1

I installed letsencrypt SSL successfully in my domain. Its hosted by Godaddy.

And used this code in .htaccess file to force redirect.

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

The site is loading fine (without loading small icons). But its showing no SSL is installed (as Chrome shows ‘Not Secure’ sign). Once I refresh the page then the secure sign is showing. I have checked in multiple browsers this problem is persistent.

This is my url. Please check seomotionz.com


#2

Hi @mrb1129

my tool doesn’t see an error ( https://check-your-website.server-daten.de/?q=seomotionz.com ):


Domainname Http-Status redirect Sec. G
http://seomotionz.com/
148.66.138.172 200 0.836 H
http://www.seomotionz.com/
148.66.138.172 200 0.850 H
https://seomotionz.com/
148.66.138.172 200 4.264 B
https://www.seomotionz.com/
148.66.138.172 200 3.827 B
http://seomotionz.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
148.66.138.172 404 0.413 A
Not Found
http://www.seomotionz.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
148.66.138.172 404 0.356 A
Not Found

Your certificate is valide:

CN=seomotionz.com
	10.02.2019
	11.05.2019
expires in 90 days	seomotionz.com, www.seomotionz.com - 2 entries

both domain names are included, both https versions are secure.

PS: The Chrome console shows some errors you should fix:

Access to font at 
'https://seomotionz.com/themes/cerise/fontawesome/fonts/fontawesome-webfont.woff2?v=4.7.0' 
from origin 'https://www.seomotionz.com' has been blocked by CORS policy: 
No 'Access-Control-Allow-Origin' header is present on the requested resource.

Chrome: Ctrl + Shift + I


#3

And also recently I have changed my site from a sub-domain to the root domain. I did the redirect through CPanel redirect option.

It was forums.seomotionz and now it should directly move to seomotionz.com

So now when I putting directly this https://forums.seomotionz.com/ its showing error

you can check. How to fix it?


#4

You can use the tool online https://check-your-website.server-daten.de/?q=forums.seomotionz.com

There is the wrong certificate:

CN=*.prod.sin3.secureserver.net, OU=Domain Control Validated
	19.04.2017
	19.04.2019
expires in 68 days	*.prod.sin3.secureserver.net, 
prod.sin3.secureserver.net - 2 entries

Is this your hoster or another domain?

The result: The connection is insecure.

Domainname Http-Status redirect Sec. G
http://forums.seomotionz.com/
148.66.138.172 301 http://seomotionz.com/ 0.383 D
http://seomotionz.com/ 200 0.950 H
https://forums.seomotionz.com/
148.66.138.172 200 6.800 N
Certificate error: RemoteCertificateNameMismatch
http://forums.seomotionz.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
148.66.138.172 404 0.393 A
Not Found

PS: So create one certificate with forums.seomotionz.com as domain name and use that.

You use cPanel, so use this integrated solution. I don’t see why the subdomain has this other certificate.


#5

Its a sub-domain where my site was previously I moved it to the root domain recently so I created a redirect through cPanel.

Should I create a redirect from https://forums.seomotionz.com to https://seomotionz.com??

Will it fix it?


#6

No.

First the browser opens a SSL-connection, then he can get the http status 301 -> “Go there”.

So a valide certificate is required before the browser sees the redirect information.


#7

So what should I do?


#8

Create a certificate with that domain name and use that. cPanel is a “closed world”, so you have to use the options there.


#9

Okay Sir, I will look into it.

Now, as I originally asked about ‘hitting the refresh’ to see the SSL. Are you sure that its not an issue?


#10

“hitting refresh” and seeing new content means your system had cached it from a previous state.
Not having ever been there, my system doesn’t require “hitting refresh” - and doing so doesn’t change the content (for me).
Nor do I ever see any “security” problem with the site.


#11

Okay, then what’s the solution for it?


#12

A cache phenomen isn’t a real problem.

Check the real answers (not the cached), if there are errors, fix these.


#13

Okay, got it. Thanks for the reply, Sir.


closed #14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.