SSL installed, but still not showing Secure Lock on browsers


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://brandculture.africa

I ran this command: SSL was installed

It produced this output: Still showing Not Secure on browsers

My web server is (include version): Apache

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Gigalayer.com

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes


#2

Hi @manuelbalogun

checked with https://check-your-website.server-daten.de/?q=brandculture.africa

Your certificate works correct with brandculture.africa, this is your certificate name.

But you have a redirect non-www -> www, your certificate doesn’t have the www-entry.

So this is a mismatch.

  • Version 1: Remove the redirect (not good)
  • Version 2: Create a new certificate with -d brandculture.africa -d www.brandculture.africa, so you have one certificate with two domain names (better).

So visitors can use your site by typing non-www + www.


#3

Thanks! Will try that.