Squarespace Site SSL Certificate Process Pending extended amount of time


#1

Please fill out the fields below so we can help you better.

My domain is:www.chelsiewalter.com

I ran this command:

It produced this output:

My operating system is (include version):

My web server is (include version):

My hosting provider, if applicable, is: Squarespace

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi @Cwalter,

Have you tried contacting squarespace support?. At first pass this seems like something they would have to help with from their end.


#3

Yes twice. They pointed me here both times… /=


#4

Do they provide any additional details, or does it just say “pending”?

Judging by Certificate Transparency logs, Let’s Encrypt has not issued any certificates for your domains yet, so your domain would not be rate limited (you can only get a certain number of certificates per domain per week). Without rate limiting in play, domain validation and certificate issuance typically takes a few seconds, so any delay on top of that would likely be caused on their end - or at least that would be what you’d have to assume if they don’t give you anything other than “pending”. :smile:


#5

That’s unfortunate! I’m sorry to hear that.

I did some investigation from the Let’s Encrypt side and it seems like attempts to create an authorization for this domain are failing because of a rate limit - specifically there are too many pending authorizations.

If you are using the Squarespace control panel to try and get HTTPS working for your website you will have to return to Squarespace support with this information & hopefully they can start fixing it for you. Unfortunately there isn’t anything we can do from our side to help in this specific case.

When you open a support ticket with them please feel free to link to this thread and specifically mention the error 429 :: urn:acme:error:rateLimited :: Error creating new authz :: Too many currently pending authorizations..

Good luck!


#6

This is what I’m currently viewing. Squarespace tech support is blaming the delay on some kind of server issue on your end.


#7

I’ll give it a shot, thanks!


#8

There were some Let’s Encrypt server availability issues yesterday so I wonder if that could be related. However, I don’t know why Squarespace support would expect this forum to be able to resolve that, if so…


#9

FYI, we’ve been communicating with Squarespace engineers and trying to isolate the problem, which may be either in our infrastructure or theirs. Seems like we’re making some progress; hopefully we’ll have an answer for you soon.


#10

Hi!

I believe the site is fixed? My SSL is no longer pending.

Thanks!


#11

Great, glad to hear it!


#12

6 posts were split to a new topic: Squarespace serving incorrect certificate


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.