Some help for a noob (albeit a noob that had this working!)


#1

Without a great understanding of what I was doing, I managed to get certificates generated by letsencrypt earlier this year and have been using them successfully on domain below. I let them expire (was just too busy at work to deal with the expiry notes) and when I went to try to renew them I didn’t seem to have certbot installed anymore. This confuses me as I wouldn’t have deleted it. Do I need to be in a specific directory to run certbot? Is the command I tried below correct?

I will reinstall certbot if necessary but it seems strange that I managed to do this last time and somehow don’t still have certbot installed on my machine.

Sorry for the complete noob questions…any help would be appreciated.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: mesberg.duckdns.org

I ran this command: sudo certbot renew

It produced this output: sudo: certbot: command not found

My web server is (include version): I don’t know

The operating system my web server runs on is (include version): raspbian stretch

My hosting provider, if applicable, is: none

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

find the certbot:
which certbot
and
cd / && find / -name certbot*

If you don’t find a certbot or certbot-auto, then just go trough the steps you first went through to install it.
Or for some guidance see:


#3

If you installed Certbot via your OS package manager (for example with yum or apt), then sudo certbot is right and it would work from any directory. If you installed with certbot-auto, then you would normally want to be in the same directory where you downloaded it and run with ./certbot-auto.


#4

Thank you. I’ll try later today.


#5

Found it and got everything working! Thank you.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.