Some challenges have failed on my own hosted server

So for about a month ago I got my first certificate, all went as planed. Now when it is running out I can't renew it, please help

My domain is: Dalaro.design

I ran this command: sudo certbot renew --dry-run

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/dalaro.design.conf


Simulating renewal of an existing certificate for dalaro.design

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: dalaro.design
Type: connection
Detail: 90.141.53.142: Fetching http://dalaro.design/.well-known/acme-challenge/1Oj9BZ7Y874fhOyfPV1fcJCBEL-F4xoQYd-rbMc_kuU: Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Failed to renew certificate dalaro.design with error: Some challenges have failed.


All simulated renewals failed. The following certificates could not be renewed:
/etc/letsencrypt/live/dalaro.design/fullchain.pem (failure)


1 renew failure(s), 0 parse failure(s)
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): NAME="Ubuntu"

VERSION="20.04.6 LTS (Focal Fossa)"

ID=ubuntu

ID_LIKE=debian

PRETTY_NAME="Ubuntu 20.04.6 LTS"

VERSION_ID="20.04"

HOME_URL="https://www.ubuntu.com/"

SUPPORT_URL="https://help.ubuntu.com/"

BUG_REPORT_URL="Bugs : Ubuntu"

PRIVACY_POLICY_URL="Data privacy | Ubuntu"

VERSION_CODENAME=focal

UBUNTU_CODENAME=focal

My hosting provider, if applicable, is: At home

This message is pretty clear, isn't it? The Let's Encrypt servers were not able to connect to your domain via HTTP. And for reference, neither am I, and neither is the letsdebug.net site. The most likely reason, as the message tells you, is that there's a firewall somewhere blocking connections on port 80. You'll need to find and fix that.

6 Likes

Sounds like that should be it, after adding a 80 and 443 rule it still does not seam to work:
sudo ufw allow 80/tcp
sudo ufw allow 443/tcp
sudo ufw reload

1 Like

Then there must be another firewall. Perhaps at your ISP, perhaps somewhere else, but there's something blocking that connection on port 80.

6 Likes

What is the error now? Because Let's Debug can now connect but you have a series of redirects which send back the wrong info to the Let's Encrypt server

The OK means the connection worked but you can see in detail the problems with the redirect

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.