[solved] DNS check works on test domain but not on live

The DNS challenge works on a test domain dev.agilebase.co.uk, where a certificate has been successfully installed, but not on the domain appserver.gtportalbase.com

The two domains are on different VPS servers but are set up similarly with the same software and OS, on the same hosting platform www.linode.com

Any ideas why that could be?

My domain is: appserver.gtportalbase.com

I ran this command:
./letsencrypt-auto certonly --manual -d appserver.gtportalbase.com --preferred-challenges dns --renew-by-default --email oliver@agilechilli.com --agree-tos

It produced this output:
Please deploy a DNS TXT record under the name
_acme-challenge.appserver.gtportalbase.com with the following value:


Before continuing, verify the record is deployed.

Press Enter to Continue
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. appserver.gtportalbase.com (dns-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.appserver.gtportalbase.com


  • The following errors were reported by the server:

    Domain: appserver.gtportalbase.com
    Type: connection
    Detail: DNS problem: NXDOMAIN looking up TXT for

My web server is (include version): Tomcat

The operating system my web server runs on is (include version):
Ubuntu 16.04 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

nslookup -q=txt _acme-challenge.dev.agilebase.co.uk
_acme-challenge.dev.agilebase.co.uk text =

nslookup -q=txt _acme-challenge.appserver.gtportalbase.com
*** UnKnown can’t find _acme-challenge.appserver.gtportalbase.com: Non-existent domain

Thanks, it turns out I was editing DNS records on the wrong nameserver. I still can’t get it to work but have opened a ticket with the hosting company, they should be able to help

To confirm it works now on when editing the DNS records in the correct place! There was just a bit of a propogation delay. Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.