DNS problem: NXDOMAIN looking up TXT for _acme-challenge.abrilcode.com - check that a DNS record exists for this domain

My domain is: abrilcode.com

I ran this command:
certbot certonly --manual -d *.abrilcode.com --agree-tos --manual-public-ip-logging-ok --preferred-challenges dns-01 --server https://acme-v02.api.letsencrypt.org/directory --register-unsafely-without-email --rsa-key-size 4096

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator manual, Installer None
Obtaining a new certificate
Performing the following challenges:
dns-01 challenge for abrilcode.com`


Please deploy a DNS TXT record under the name
_acme-challenge.abrilcode.com with the following value:

f4u1bbJd1Esj5QJGC3aOtSeOdDHwXFJS2IfKIChxMRk

Before continuing, verify the record is deployed.


Press Enter to Continue
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. abrilcode.com (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.abrilcode.com - check that a DNS record exists for this domain

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: abrilcode.com
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.abrilcode.com - check that a DNS record exists for
    this domain

My web server is (include version): hostinger shared hosting, i don't know the server technical specifications

My hosting provider, if applicable, is: hostinger

I can login to a root shell on my machine (yes or no, or I don't know): i can not root log in

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): hpanel (hostinger own panel)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.28.0

I'm trying to get a ssl wildcard certificate from my local computer to use them manually in my hostinger shared server hpanel, because is the only way i can do it now: i don't have root access to the server. I have already a lifetime ssl certificate which hostinger gave me when i payed for the service. But i have 4 subdomains that i would like to certificate, so i would like to generate only one wildcard certificate to use it from hpanel in hostinger.

The point is that i cannot create neither specific ssl certificate for one subdomain nor wildcard certificate for all subdomains.

Same problem i have with my local version of certifytheweb for windows. I could create first certificates 2 months ago, but same problem now.

I attached a screenshot.

Thanks in advance

2 Likes

Hello @f_hauk,

Don't create the TXT record as _acme-challenge.abrilcode.com use just _acme-challenge because your DNS hosting is appending the domain to the record so you get this:

$ dig _acme-challenge.abrilcode.com.abrilcode.com txt +short
"f4u1bbJd1Esj5QJGC3aOtSeOdDHwXFJS2IfKIChxMRk"

Cheers,
sahsanu

4 Likes

Thank you so much sahsanu, now it works. How beautiful is when oneself know what he's doing!! Have a good day!

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.