Site not loading on some mobile browser


#1

hello
i have two site on my server with lets encrypt ssl and both working good on my own browser
1)bazmineh.com
2)bitdefendercenter.ir

but the problem is some mobile users cant see bazmineh.com but all can access bitdefendercenter.ir .

it show this error

how can i fix the problem ?!

My web server is (include version): Apache & nginx with plesk
The operating system my web server runs on is (include version): ubuntu 16
My hosting provider, if applicable, is: dedicated server
I can login to a root shell on my machine (yes or no, or I don’t know): yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):plesk


#2

Any chance of seeing what’s inside the “details” link in that screenshot?

What country are the visitors having problems from?


#3

the visitor country is “iran” but the users checking second site at the same time and dont face any problem…


#4

While the sites are hosted on the same network AS, they are on separate subnets, and comparing the two hosts on a looking glass in Iran (http://lg.iranet.ir), I believe that this one can probably be chalked up to network issues.


#5

Are you getting any additional reports outside of Iran?

I did notice that you list all 4 nameservers using a single IP for bazmineh.com at the registrar where-as only two of those are configured within the dnszone file when digging it directly:

dig ns bazmineh.com +short
ns2.bazmineh.com.
ns1.bazmineh.com.

If nothing else you’ll want to get NS lines added for the remaining two. Past that the world seems fine as far as DNS resolution goes.

If the problem still persists you may want to check and see if they can access the site directly via IP on mobile to eliminate any name based blocks.


#6

it seems outside of Iran thre is no problem :expressionless:

i added two other records for dns!

also attached access from ip to server

i think i must wait to two new dns resolve …


#7

So it seems direct IP access works, and it’s just name based. Could be possible that those nameservers are blocked by the mobile provider or they are refusing to update that domain / zone.

Did adding the additional servers help bypass things?