"secure connection failed" on www subdomain


#1

Installed Let’s Encrypt cert on planetrockwall.com using the Plesk extension. A few bumps in the road later, all works well. EXCEPT the www subdomain returns a “Secure Connection Failed” page showing the error code SSL_ERROR_NO_CYPHER_OVERLAP. In the install process, I made sure the “nclude a “www” subdomain for the domain and each selected alia se.g. www.planetrockwall.com” box was checked during install. Can’t implement HSTS if all subdomains not secure, and there is still a bunch of marketing material out there with the www address on it. Not good for business. Help!


#2

You’re using Cloudflare CNAME’ing for your www subdomain but not for your primary domain.

That probably accounts for your problem.

Most likely, you have Universal SSL disabled in Cloudflare, Cloudflare has yet to issue your certificate, or there’s something preventing Cloudflare from issuing a certificate for you.

$ dig +short planetrockwall.com
72.47.250.76

$ dig +short www.planetrockwall.com
www.planetrockwall.com.cdn.cloudflare.net.
104.27.175.197
104.27.174.197

#3

Thanks for the tip. I tried a number of adjustments to Cloudflare settings to no avail. Finally disabling Cloudflare for this subdomain altogether solved the problem.


#4

That doesn’t sound like a real “long-term” fix to this problem.
This sounds more like, “Since my steering wheel is broken and can’t turn left, I will only make right turns!”
[ BOOM! Problem: SOLVED ]

You may need to review how the other sites are able to have certs and use CloudFlare.
There must be some difference(s) there that can explain what is causing this problem.

Good luck.
If there is any way we can help, feel free to just ask.


closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.