Renewal successful but not showing as valid cert


#1

Please fill out the fields below so we can help you better.

My domain is: elizabethonmain.com

I ran this command: ./certbot-auto renew --dry-run

It produced this output: Successful

My operating system is (include version): MacOS X 10.11.6

My web server is (include version): Apache/2.4.18

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

So I renewed my certificate using the above command and it successfully ran but when I go to the website, it says that the cert is 27 days old. I tried clearing my cache. What am I doing wrong?


#2

Depending on how you initially acquired the certificate, you might have to reload your web server after renewal in order for the web server to start using the new certificate. You can combine this with the renew command using --post-hook, e.g. ./certbot-auto renew --post-hook "apache2ctl graceful"

The exact command for reloading apache depends on your server OS.


#3

That did it! I completely forgot about this. Thank you!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.