My certificate is not renewed


#1

Hello, I have installed certbot / letsencrypt for more than 90 days, now my certificate has expired, and I can no longer validate it … when I run the ./certbot-auto renew command, it notifies me that it has been completed, but the site continues With error.


#2

How did you run certbot in the first place? Which commands? Which plugins are used?

Did you reload/restart your webserver? Does the webserver configuration point to the correct files?

What is the exact output of certbot renew?


#4

I was actually meaning the first time you ran certbot, but the output helps enough :slight_smile:

This indicates you have succesfully renewed your certificate, but your webserver needs to be reloaded to load the new certificate before it can be used. This would indicate you have used certbot-auto in the certonly mode when you originally requested the certificate.

Well, actually, you’re probably using the webroot plugin :wink: Internally, they are called plugins :slight_smile:

But anyhow, reload your webserver and you’ll be fine. Next time you can run certbot-auto renew --renew-hook "${command_to_reload_your_webserver}" (where ${command_to_reload_your_webserver} is obviously replaced with the command needed to reload your webserver ;)), so you won’t have to do that manually.


#5

I already did service apache2 restart, but nothing worked.


#6

What is the value of SSLCertificateFile and SSLCertificateKeyFile of the Apache configuration in question?


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.