Problem with renewal using certbot-auto

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
./certbot-auto renew

It produced this output:
Upgrading certbot-auto 0.17.0 to 0.19.0…
Replacing certbot-auto…
Requesting to rerun ./certbot-auto with root privileges…
Creating virtual environment…
Installing Python packages…
Installation succeeded.
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for
Waiting for verification…
Cleaning up challenges

new certificate deployed without reload, fullchain is

Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/ (success)

My web server is (include version):
Apache 2

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
AWS Lightsail

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

I ran the command to renew the Let’s Encrypt certificate

./certbot-auto renew

from within the certbot directory. This ran successfully.

However, when I get the cert info from the browser, the expiration date has not changed.

Should I see that change? If yes, what did I do wrong?

It looks like you used the “certonly” command when requesting your certificate originally. That means you need to reload your Apache configuration after you renew. Since you didn’t specify your operating system and I’m not familiar with Lightsail, I can only guess that this means something like sudo service apache2 reload or sudo systemctl reload apache2.

If you want this to happen automatically after each renewal, see the documentation for --deploy-hook here.

1 Like

Yes, I forget to restart Apache. Have done so now and all is good. Thank you for your reply.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.