Renewal of certificates

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
www.batcavelounge.eu
I ran this command:
sudo certbot renew --dry-run
It produced this output:

Processing /etc/letsencrypt/renewal/www.batcavelounge.eu.conf

Attempting to parse the version 0.33.1 renewal configuration file found at /etc/letsencrypt/renewal/www.batcavelounge.eu.conf with version 0.22.2 of Certbot. This might not work.
Cert is due for renewal, auto-renewing…
Could not choose appropriate plugin: The requested nginx plugin does not appear to be installed
Attempting to renew cert (www.batcavelounge.eu) from /etc/letsencrypt/renewal/www.batcavelounge.eu.conf produced an unexpected error: The requested nginx plugin does not appear to be installed. Skipping.


Processing /etc/letsencrypt/renewal/batcavelounge.eu.conf

Attempting to parse the version 0.33.1 renewal configuration file found at /etc/letsencrypt/renewal/batcavelounge.eu.conf with version 0.22.2 of Certbot. This might not work.
Cert is due for renewal, auto-renewing…
Could not choose appropriate plugin: The requested nginx plugin does not appear to be installed
Attempting to renew cert (batcavelounge.eu) from /etc/letsencrypt/renewal/batcavelounge.eu.conf produced an unexpected error: The requested nginx plugin does not appear to be installed. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/www.batcavelounge.eu/fullchain.pem (failure)
/etc/letsencrypt/live/batcavelounge.eu/fullchain.pem (failure)


** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates below have not been saved.)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/www.batcavelounge.eu/fullchain.pem (failure)
/etc/letsencrypt/live/batcavelounge.eu/fullchain.pem (failure)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)

2 renew failure(s), 0 parse failure(s)
My web server is (include version):
nginx
The operating system my web server runs on is (include version):
UBUNTU 16.04
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
YES
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-cauto --version if you’re using Certbot):certbot 0.22.2

Hi @batcave,

It looks like you probably have both certbot-auto and certbot installed, and you originally used certbot-auto when requesting the certificate. If so, you should try to use certbot-auto for the renewal as well.

:~/letsencrypt$ certbot-auto
certbot-auto: command not found

certbot-auto is never in your PATH and always has to be run by specifying a directory, like ./certbot-auto if you’re in the appropriate directory.

You might check

① your own memory or any documentation that you used when requesting the original certificate,
history | grep certbot,
locate certbot-auto

locate certbot-auto
/etc/nginx/sites-available/certbot-auto
/opt/eff.org/certbot/venv/certbot-auto-bootstrap-version.txt

Those are the only two lines of output?

Did you follow a particular tutorial or documentation when you obtained your certificate?

Which names would you like to activate HTTPS for?


1: batcavelounge.eu
2: www.batcavelounge.eu


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 2
Cert is due for renewal, auto-renewing…
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for www.batcavelounge.eu
Waiting for verification…
Cleaning up challenges
Deploying Certificate to VirtualHost /etc/nginx/sites-enabled/default

Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.


1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you’re confident your site works on HTTPS. You can undo this
change by editing your web server’s configuration.


Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel):

Is this output that you received just right now? If so, it looks like it worked!

Yes, i just have to choose which one i believe i had option 2 Redirect

I’m not sure why this question is being asked now but I don’t think there’s any problem with answering 2 (this behavior will become automatic in a future version of Certbot and then Certbot won’t even ask).

It looks like your new certificate is live on your site now!

Your existing certificate has been successfully renewed, and the new certificate
has been installed.
IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:

Thank you Very Much for the Great Quick response and help, =-)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.