Certificate renewal - Nginx

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: slingr.me

I ran this command: sudo certbot renew --dry-run

It produced this output: “The requested apache plugin does not appear to be installed”

My web server is (include version): nginx/1.17.10

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): N/A

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.40.0

1 Like

Hi @das924

why do you use the Apache plugin if you have a nginx?

Please read the documentation and use a correct command.

2 Likes

That’s the odd thing. I don’t ever recall using the Apache plugin. In fact, thinking I made some mistake, when I tried to install the nginx plugin (sudo apt install certbot python3-certbot-nginx), it was already installed. Also, the server block setup in for my nginx config is properly configured, and my site routes to https without issue. I’m just trying to renew the certificate and that error caught me off guard.

1 Like

In that case, can you try to switch your configuration for that site?

Warning: Backup your configuration before you proceed
Backup:
cp /etc/letsencrypt/renewal /a_path/to/somewhere_else

Switch authenticator: (Specify all domains included in that certificate with -d flag)
sudo certbot renew --dry-run --authenticator nginx -d domain1 -d domain2

Thank you

1 Like

Check your Certbot config files. May be you have used the wrong tutorial.

1 Like

When I try the certbot renew command, I get the following message:
“Currently, the renew verb is capable of either renewing all installed certificates that are due to be renewed or renewing a single certificate specified by its name. If you would like to renew specific certificates by their domains, use the certonly command instead…”

Thank you

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.