Can't renew certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot renew --cert-name --nginx

It produced this output: Attempting to renew cert ( from /etc/letsencrypt/renewal/ produced an unexpected error: The requested nginx plugin does not appear to be installed. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)

My web server is (include version): NGINX

The operating system my web server runs on is (include version): Ubuntu 16.04

My hosting provider, if applicable, is: cafe24

I can login to a root shell on my machine (yes or no, or I don’t know): don’t know, but I usually use sudo

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.23.0

Why are you adding --nginx? Most of the time, it would suffice to just run certbot renew without any other options. If you specifically only want that single certificate renewed, indeed you can add the --cert-name option. But adding --nginx shouldn't be required. It looks to me like you've never used it before either, as the plugin isn't installed anyway.

1 Like

Thank you for responding. I just solved the issue. The way I solved it was the directions found on this page:

I didn’t realize that I needed to install anything additional since certbot was installed and I had access to commands like run.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.