Remove ssl cert from blogger custom domain

At this point I am pretty desperate.

An SEO “expert” friend told me I needed enable https for my custom domain blogger site www.hancockshouseofhappy.com

So I went to the settings at blogger and flipped the switch from yes to no. And some how just ended up with a certificate from letsencrypt even though I didn’t provide any details of ownership or anything that I can remember. It was only about a week ago.

As a result my CPC and ad impressions have been 0 and now I can’t seem to turn it of. Or rather I can turn off the https in blogger settings but can’t turn off the redirect.

At this point I just want to be got rid of it. It has been a total disaster.

My domain reg is 123reg.

How do I get rid of this?

I’m not seeing any redirect.

By the way, only your www subdomain works. But it doesn’t have a redirect to HTTPS. Surfing to http://hancockshouseofhappy.com results in a 123reg placeholder site. No redirect.

Manually surfing to https://www.hancockshouseofhappy.com results in a ERR_CONNECTION_CLOSED from my browser and using OpenSSL as a client also results in an error: handshake failure.

Those errors generally aren’t directly related to a SSL certificate, but related to webserver configuration issues.

Also, as you “just flipped a switch”, I don’t think there is anything you can do about this kind of issues besides trying to flip switches back again.

I would suggest asking your webhosting company (Blogger?) for support in this matter.

thank you so much for replying so quickly. I will also take this up with blogger. I turned off https but the settings on the blogger control panel are still showing as redirect being enabled and I can’t seem to disable it. I was assuming this might be because there is a certificate in existence for it and that is what is gumming everything up. Also thank you for the your advice on the subdomain. However, I am not able to get this switched over easily. I am getting help from the domain registrar.

Can you make a screenshot? I’m not really understanding what exactly is redirected, because I’m not seeing such a redirect.

Not sure if you can see that image but essentially on Blogger there are two settings for https.

One where you just turn it on and (at least this is my experience) you some how magically get issued with a letsencrypt cert. I currently have this set to NO. It was YES but then that was when issues with adsense etc started so I set it to NO again.

And then there is a second setting that says HTTPS redirect (yes or no):

If HTTPS Redirect is turned on:
Visitors to your blog will always go to https ://www.hancockshouseofhappy.com.

If HTTPS Redirect is turned off:
Visitors to http ://www.hancockshouseofhappy.com will be served over HTTP, an unencrypted connection.
Visitors to https ://www.hancockshouseofhappy.com will be served over HTTPS, an encrypted connection.

So I have set the first setting to NO but it will not let me set the second setting to NO which makes it look like even if HTTPS is off people are still being directed there. I don’t think that is what is happening as I don’t get redirected to HTTPS so it might be that the Bogger UI or whatever is just crap. Because I CAN set this second setting to NO if the first one is set to YES but if the first one is set to NO there is no way to change this second one to yes.

I don’t know if that is because there is a certificate in existence or Blogger is rubbish. Most likely Blogger is just rubbish. But I am concerned that there is now this certificate in existence that I can’t get set up with my domain registrar and I don’t really need or want. Do I just have to wait 90 days for it to expire?

Anyways, that is probably way more information than you needed on a Sunday afternoon and I greatly appreciate your help.

Hi @houseofhappy

that’s an inactive setting, so that doesn’t have an effect.

And you don’t have redirects:

Domainname Http-Status redirect Sec. G
http://hancockshouseofhappy.com/
94.136.40.51 200 0.063 H
http://www.hancockshouseofhappy.com/
172.217.19.211 200 0.516 H
http://www.hancockshouseofhappy.com/
172.217.23.147 200 0.360 H
http://www.hancockshouseofhappy.com/
2a00:1450:400e:80e::2013 200 0.594 H
https://hancockshouseofhappy.com/
94.136.40.51 200 0.487 N
Certificate error: RemoteCertificateNameMismatch
https://www.hancockshouseofhappy.com/
172.217.19.211 -4 0.093 W
SendFailure - The underlying connection was closed: An unexpected error occurred on a send. Authentication failed because the remote party has closed the transport stream.

A redirect would show a http status 301 / 302.

http status 200 -> no redirect.

That’s because without HTTPS, that redirection isn’t making sense. It’s option is disabled as HTTPS is disabled.

But that’s not the case. There is no such redirect.

Unfortunately, because you’ve activated that redirect in the past, the button stays like that saying “Yes”. But it should have been updated to “No” automatically when the redirect was also automatically removed when HTTPS was disabled.

You have a HTTP only site now. I’m no SEO expert, but currently there is no redirect on your site, so that cannot be the problem with your CPC.

What could be a SEO problem, might be the removal of your HTTPS version of the site: Google gives higher rankings to properly configured HTTPS sites. Removing the HTTPS might give you a penalty.

1 Like

Thank you very much for you help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.