[Rate limit] Too many certs issues for exact set of domains


#1

Hello,

I have looked at other topics with similar issues, I just want some newer information.

I’ve attempted to install a certificate for my domain on a Gitlab-CE instance. I was messing around, trying to get settings correct… many times I failed to create/apply a cert, eventually I got the settings correct, however I then hit a rate limit - apparently too many certs have been issued for my domain.

How long do I have to wait for the ratelimit to pass?

Thanks.

Edit:
https://letsencrypt.org/docs/rate-limits/ - After looking here, I’m not sure why I’m getting this message - I certainly don’t think I’ve hit any of the mentioned limits.

Edit #2: I went ahead and changed the domain to include www. I now have a certificate.

Thanks anyways. :slight_smile:


#2

If you want to come back and get a cert for your original domain, you have to wait 7 days. It’s a rolling 7, so it’s 7 days from when you hit the limit (as opposed to Sunday to Sunday or something).

Glad you got a cert in the meantime :slight_smile:


#3

Hi,

Thanks for the reply.

I’ve set it up so no matter if I visit the site with www. prepended or not, I’m still routed to it eventually (so I’m covering the whole domain, if that makes sense).


#4

I think it does - I’ve kinda done the same thing but in reverse - for me the www redirects to my main site which is encrypted, and I didn’t bother getting a cert for the www sub :stuck_out_tongue_winking_eye:


#5

Hi,

Awesome, as long as you’ve got it set up how you like :slight_smile:


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.