Query timed out looking up A

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: hardebol.nl

I ran this command: /usr/bin/certbot certonly -d www.hardebol.nl

It produced this output: Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: www.hardebol.nl
Type: dns
Detail: DNS problem: query timed out looking up A for www.hardebol.nl; DNS problem: query timed out looking up AAAA for www.hardebol.nl

My web server is (include version): Apache/2.4.29 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.4.6 LTS

My hosting provider, if applicable, is: self hosted

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.31.0

I have several websites that I can easily get a certificate for. But some give the above error.
I have been struggeling with this for weeks. I tested my DNS against almost every dns checker out there. No firewall is blocking anything. Port 53 is open for both UDP and TCP.

tried --manual.. same result

Please help,

Regards OHb

Well, the first test I ran showed a bunch of DNS issues:


It looks like at the very least your DNSSEC is misconfigured, one of your glue records is wrong, and some of your servers aren't responding to UDP.


The results of https://dnsspy.io/ can be found here https://dnsspy.io/scan/hardebol.nl

1 Like

Neither of the Authoritative Name Servers are serving up answer for the Domain Name; this is a DNS issue.

$ nslookup
> hardebol.nl

Non-authoritative answer:
Name:   hardebol.nl
> set q=soa
> hardebol.nl

Non-authoritative answer:
        origin = ns1.hardebol.nl
        mail addr = hostmaster.hardebol.nl
        serial = 2022102509
        refresh = 28800
        retry = 7200
        expire = 1209600
        minimum = 86400

Authoritative answers can be found from:
> server ns1.hardebol.nl
Default server: ns1.hardebol.nl
> set q=a
> hardebol.nl
;; connection timed out; no servers could be reached
> server ns2.hardebol.nl
Default server: ns2.hardebol.nl
> hardebol.nl
;; connection timed out; no servers could be reached

Since these are Domain Validation (DV) certificates the Domain Name System (DNS) is used extensively in the validation process as well a allowing us to assist here on Let's Encrypt community.
DNS Queries need to give consistent results from any location on the Internet, all your authoritative DNS Servers for the Domain need to also give consistent results as well.

Testing and debugging are best done using the Staging Environment as the Rate Limits are much higher. Rate Limits are per week (rolling).

And to assist with debugging there is a great place to start is Let's Debug.

1 Like

Whois Record for Hardebol.nl Whois Lookup Captcha
and IP Whois Lookup, Domain Name Search, Visual Trace Route - Da whois

and from .NL domain WHOIS Search | EuroDNS

1 Like

Interestingly, from the same country (NL), the DNS works fine.

Perhaps OP has some geo-blocking active?


And Let's Encrypt uses Multi-Perspective Validation Improves Domain Validation Security - Let's Encrypt.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.