Fail to update certificate DNS Query Timeout

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot certonly --webroot -w /var/www/nextcloud -d

It produced this output:
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.


My web server is (include version):

The operating system my web server runs on is (include version):
dietpi 8.11.2

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


Hello @rockfranky, welcome to the Let's Encrypt community. :slightly_smiling_face:

You have a DNS issue for the domain name.

Using this online tool yields these results Let's Debug

Using this online tool shows in DNS not responding for large portions of the world these results Multi-country domain resolving with DNS service: Check host - online website monitoring


Hello Bruce,
thanks for your quick reply. I saw that I typed the wrong URL. The correct one is:

but the result is the same. So, to me it then is an issue with my DnyDNS provider (TwoDns), isn´t it ?

1 Like

Yes, you need your DNS working first in order to get a certificate (as well as in order for people to be able to connect to your site).


Yeah, DNS still not working well

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.