Port 443 Closed after installing SSL certificates on server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: destpark.com

I ran this command: sudo certbot certonly to spin up a temporary webserver

It produced this output: Your certificate and chain have been saved at: (certificate was successfully generated)

My web server is (include version): Websited hosted on Azure VM

The operating system my web server runs on is (include version): UbuntuServer-18.04-LTS

My hosting provider, if applicable, is: azure dns

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.31.0

certbot certonly in combination with the standalone plugin doesn't modify your webserver configuration in any way, not even to authorize the challenge. So it could not have caused anything at port 443.

1 Like

Thank you for your quick response @Osiris. I tried to using Lets Encrypt with Nginx, but when I spin up my web app, it throws an error, " Error bind: address already in use" But port 443 is now open though not to my web app. Any advise will go along way

1 Like

That suggests you were trying to use the standalone plugin while nginx is running. certbot also has a nginx plugin which can make use of your running nginx in most instances. Sometimes the nginx configuration is a little bit non-standard though and the certbot nginx plugin could have some issues. But even then it's probably perfectly possible to get a certificate without using the standalone plugin.

1 Like

That would be placing files in my webroot directory. Will my webserver configuration be modified?

Not if you use certonly with the --webroot option. See the certbot documentation for more info.

You'd need to modify your webserver configuration manually to actually use the file in nginx of course.


Thank you @Osiris , I'll go though the documentation.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.