Plesk: Invalid response to HTTP-01 challenge, 404

Please fill out the fields below so we can help you better.

My domain is:

I ran this command: renew certificate from Plesk backend

It produced this output: Fehler: Fehler bei der Installation des SSL-Zertifikats von Let’s Encrypt: Challenge marked as invalid. Details: Invalid response from “<!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
<title>404 Not Found</title>
<h1>Not Found</h1>

My web server is (include version): 2.4.7

The operating system my web server runs on is (include version): Ubuntu 14.04.5

My hosting provider, if applicable, is: Strato

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Onyx (17.0.17)

I noticed that I was flagged false positive on spamcannibal because my server seems to be anonymous.
I’m on it to solve this, just some side info, maybe it’s the cause why I won’t get a certificate anymore.

Thank you.

The only service we check for reputational purposes is Google Safe Browsing and a separate distinct error type is returned for hits. This looks like an unrelated issue.

I'm not familiar with Plesk but I will update the thread topic to make it clearer what kind of expertise would be helpful here.


We just had two threads with the same error in Plesk. Note that both of the people had IPv6 addresses. Could this be a case of more providers giving users IPv6 addresses that they didn’t expect?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.