Unable to obtain Let's Encrypt SSL certificate because of failed challenge for domain


Domain name is the-devils-sanctum.info
Plesk Onyx
Version 17.5.3 Update #16

Few days ago we got email about we need to renew SSL Encrypt as about to expire we’re currently getting this error message. I’m re-sellers for the Customer, i just want to renew and will not allow us to-active it saying about to expire.

Hosting Provider OVH - Contacted them about the on-going issues wasn’t helpful contacted Plesk about the same problem none of them on forum able to help me with the currently issues facing.

Errors :

Error: Unable to obtain Let’s Encrypt SSL certificate because of failed challenge for domain “”:
Invalid response from /.well-known/acme-challenge/OdfJC0RYAsXPbsu1MWmgaKgbdmS3J5RXoncqnw9iEpE: " 500 Internal Server Error <B"


I’ve re-write the httaccess file and now getting this error

Error: Unable to obtain Let’s Encrypt SSL certificate because of incorrect DNS configuration for domain (Domain)-Name)

Global DNS contains an AAAA record for IPv6, but in Plesk the domain is assigned only an IPv4 address. To resolve the issue, either add an IPv6 address via Web Hosting Access settings, or remove the AAAA record from the global DNS for the domain. See the related Knowledge Base article for details.

Original error message:
Invalid response from Domain name .well-known/acme-challenge/QYElTN5i__adObFEg2fHBKSvF6CqBN2UxGLlOXPby68: " 404 Not Found

Not Found


I’m getting another error.

Hello, Can anyone shed some light on this…

i’m unable to fix this problem getting cause now i’ve hit the limit cap.

Error: Let’s Encrypt SSL certificate installation failed:
Invalid response from https://acme-v01.api.letsencrypt.org/acme/new-authz: Error creating new authz :: Too many invalid authorizations recently… Type: urn:acme:error:rateLimited.


First off, you should add the --dry-run flag to your certbot commands until you get this working. That will execute against the staging environment, which has separate and much higher rate limits.

Next, that error indicates whatever server is responding is failing to serve the challenge file from domain.com/.well-known/acme-challenge. Perhaps try placing a test file in that directory and ensure you can load it from your browser. Let us know how that goes.

Thank for your message, Plesk contacted me back regrading this problem.

I’m going let you know how resolved this problem… It’s BUG in plesk they currently working on fix to fix the on-going problem.

Open Plesk Control Panel - Click on Tool & Settings - Plesk. (GREAT)
Let’s get going…Tools & Resources under that header you will see
IP Addresses
Click on it
Change IPV4 address to Shared.
Change IPV6 address to Dedicated.
Once done save the changes.
Great Prefect, Let’s go to the next part now we need to click on Domains
selected the domain name. Now selected File-Manager.

You need to rename your .htaccess to .htaccess.test this only temporary we’ll change this back soon.
Save the re-named file name.

Click on Domains choose your Domain name. Click on Web Hosting Access

You will see in here you have IP Addresses, Information banner looking like this.
Here you can view the IP addresses associated with your subscription and change the username and password of your system user.

Please remember this only Temporary, Click on IP Address IPV4 and change it too NONE. Great now apply the change.

Now once you have applied the changes, click on domains and selected Let’s Encrypt.
Click Renew - And will re-new SSL prefect. you should get this message - Information: Let’s Encrypt SSL certificate was successfully installed on

Great, Do you remember we had to change the .htaccess file name - go back to your file-manager and rename back to .htaccess save the changes once again. Now you need to go back into “Web-Hosting-Access” again and switch IPV4 address back online. Just let you know can now leave this on as no longer get this error message.

Remember always test Encrypt again with these settings switched on as shouldn’t no longer get this error anymore.

When you receive email saying need to re-new SSL will work by click on re-new prefect.

I’m sorry didn’t add any images will added some later in showing how i fixed this error with images also.

Let’s Encrypt

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.