Plesk 12.5 [Debian 7.9] Error by create a SSL


#1

Hey, i have set a new Debian 7.9 vServer with Plesk 12.5.

Now im have the Problem that Plesk/LetsEncrypt me say:

Fehler: Fehler bei der Installation des
SSL-Zertifikats von Let’s Encrypt: Failed letsencrypt execution:
Traceback (most recent call last):

File "/opt/psa/var/modules/letsencrypt/venv/bin/letsencrypt", line 11, in <module>

sys.exit(main())

File
"/usr/local/psa/var/modules/letsencrypt/venv.9b7lw/local/lib/python2.7/site-packages/letsencrypt/cli.py",
line 1950, in main

plugins = plugins_disco.PluginsRegistry.find_all()

File
"/usr/local/psa/var/modules/letsencrypt/venv.9b7lw/local/lib/python2.7/site-packages/letsencrypt/plugins/disco.py",
line 168, in find_all

plugin_ep = PluginEntryPoint(entry_point)

File
"/usr/local/psa/var/modules/letsencrypt/venv.9b7lw/local/lib/python2.7/site-packages/letsencrypt/plugins/disco.py",
line 31, in init

self.plugin_cls = entry_point.load()

File
"/usr/local/psa/var/modules/letsencrypt/venv.9b7lw/local/lib/python2.7/site-packages/pkg_resources/init.py",
line 2201, in load

self.require(*args, **kwargs)

File
"/usr/local/psa/var/modules/letsencrypt/venv.9b7lw/local/lib/python2.7/site-packages/pkg_resources/init.py",
line 2218, in require

items = working_set.resolve(reqs, env, installer)

File
"/usr/local/psa/var/modules/letsencrypt/venv.9b7lw/local/lib/python2.7/site-packages/pkg_resources/init.py",
line 835, in resolve

raise VersionConflict(dist, req).with_context(dependent_req)

ContextualVersionConflict: (cryptography 1.1
(/opt/psa/var/modules/letsencrypt/venv.9b7lw/lib/python2.7/site-packages),
Requirement.parse(‘cryptography>=1.3’), set([‘PyOpenSSL’]))

What can i do to Fix it ?


#2

the same issue on ubuntu 14.04 with Plesk 12.5


#3

I have the same issue.
Plesk 12.5.30 | Debian 8.3

Fehler: Fehler bei der Installation des
SSL-Zertifikats von Let’s Encrypt: Failed letsencrypt execution:
Traceback (most recent call last):

File "/opt/psa/var/modules/letsencrypt/venv/bin/letsencrypt", line 11, in <module>

sys.exit(main())

File
"/usr/local/psa/var/modules/letsencrypt/venv.eBJVm/local/lib/python2.7/site-packages/letsencrypt/cli.py",
line 1950, in main

plugins = plugins_disco.PluginsRegistry.find_all()

File
"/usr/local/psa/var/modules/letsencrypt/venv.eBJVm/local/lib/python2.7/site-packages/letsencrypt/plugins/disco.py",
line 168, in find_all

plugin_ep = PluginEntryPoint(entry_point)

File
"/usr/local/psa/var/modules/letsencrypt/venv.eBJVm/local/lib/python2.7/site-packages/letsencrypt/plugins/disco.py",
line 31, in init

self.plugin_cls = entry_point.load()

File
"/usr/local/psa/var/modules/letsencrypt/venv.eBJVm/local/lib/python2.7/site-packages/pkg_resources/init.py",
line 2201, in load

self.require(*args, **kwargs)

File
"/usr/local/psa/var/modules/letsencrypt/venv.eBJVm/local/lib/python2.7/site-packages/pkg_resources/init.py",
line 2218, in require

items = working_set.resolve(reqs, env, installer)

File
"/usr/local/psa/var/modules/letsencrypt/venv.eBJVm/local/lib/python2.7/site-packages/pkg_resources/init.py",
line 835, in resolve

raise VersionConflict(dist, req).with_context(dependent_req)

ContextualVersionConflict: (cryptography 1.1
(/opt/psa/var/modules/letsencrypt/venv.eBJVm/lib/python2.7/site-packages),
Requirement.parse(‘cryptography>=1.3’), set([‘PyOpenSSL’]))


#4

same Problem here with a Plesk 12.5.30 and Debian 8.3

Fehler: Fehler bei der Installation des SSL-Zertifikats von Let's Encrypt: Failed letsencrypt execution: Traceback (most recent call last): File "/opt/psa/var/modules/letsencrypt/venv/bin/letsencrypt", line 11, in <module>; sys.exit(main()) File "/usr/local/psa/var/modules/letsencrypt/venv.6JZQ8/local/lib/python2.7/site-packages/letsencrypt/cli.py", line 1950, in main plugins = plugins_disco.PluginsRegistry.find_all() File "/usr/local/psa/var/modules/letsencrypt/venv.6JZQ8/local/lib/python2.7/site-packages/letsencrypt/plugins/disco.py", line 168, in find_all plugin_ep = PluginEntryPoint(entry_point) File "/usr/local/psa/var/modules/letsencrypt/venv.6JZQ8/local/lib/python2.7/site-packages/letsencrypt/plugins/disco.py", line 31, in __init__ self.plugin_cls = entry_point.load() File "/usr/local/psa/var/modules/letsencrypt/venv.6JZQ8/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2201, in load self.require(*args, **kwargs) File "/usr/local/psa/var/modules/letsencrypt/venv.6JZQ8/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2218, in require items = working_set.resolve(reqs, env, installer) File "/usr/local/psa/var/modules/letsencrypt/venv.6JZQ8/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 835, in resolve raise VersionConflict(dist, req).with_context(dependent_req) ContextualVersionConflict: (cryptography 1.1 (/opt/psa/var/modules/letsencrypt/venv.6JZQ8/lib/python2.7/site-packages), Requirement.parse('cryptography&gt;=1.3'), set(['PyOpenSSL']))


#5

Same Problem, Centos 7, Plesk 12.5.30

Error: Let’s Encrypt SSL certificate installation failed: Failed letsencrypt execution: Traceback (most recent call last):
File “/usr/local/psa/var/modules/letsencrypt/venv/bin/letsencrypt”, line 11, in <module>
sys.exit(main())
File “/usr/local/psa/var/modules/letsencrypt/venv.7nNoz/lib/python2.7/site-packages/letsencrypt/cli.py”, line 1950, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/local/psa/var/modules/letsencrypt/venv.7nNoz/lib/python2.7/site-packages/letsencrypt/plugins/disco.py”, line 168, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/local/psa/var/modules/letsencrypt/venv.7nNoz/lib/python2.7/site-packages/letsencrypt/plugins/disco.py”, line 31, in init
self.plugin_cls = entry_point.load()
File “/usr/local/psa/var/modules/letsencrypt/venv.7nNoz/lib/python2.7/site-packages/pkg_resources/init.py”, line 2201, in load
self.require(*args, **kwargs)
File “/usr/local/psa/var/modules/letsencrypt/venv.7nNoz/lib/python2.7/site-packages/pkg_resources/init.py”, line 2218, in require
items = working_set.resolve(reqs, env, installer)
File “/usr/local/psa/var/modules/letsencrypt/venv.7nNoz/lib/python2.7/site-packages/pkg_resources/init.py”, line 835, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (cryptography 1.1 (/usr/local/psa/var/modules/letsencrypt/venv.7nNoz/lib/python2.7/site-packages), Requirement.parse(‘cryptography>=1.3’), set([‘PyOpenSSL’]))


#6

I found out that letsencrypt uses a local python instead of the system wide one. So, here’s the fix:

  • Go to your server’s shell as root
  • cd /usr/local/psa/var/modules/letsencrypt/venv/bin
  • ./pip install --upgrade cryptography

#7

root@Sn0x:~# cd /usr/local/psa/var/modules/letsencrypt/venv/bin
root@Sn0x:/usr/local/psa/var/modules/letsencrypt/venv/bin# ./pip install --upgrade cryptography
Collecting cryptography
Using cached cryptography-1.3.tar.gz
Requirement already up-to-date: idna>=2.0 in /opt/psa/var/modules/letsencrypt/venv.awDqz/lib/python2.7/site-packages (from cryptography)
Requirement already up-to-date: pyasn1>=0.1.8 in /opt/psa/var/modules/letsencrypt/venv.awDqz/lib/python2.7/site-packages (from cryptography)
Requirement already up-to-date: six>=1.4.1 in /opt/psa/var/modules/letsencrypt/venv.awDqz/lib/python2.7/site-packages (from cryptography)
Requirement already up-to-date: setuptools>=11.3 in /opt/psa/var/modules/letsencrypt/venv.awDqz/lib/python2.7/site-packages (from cryptography)
Requirement already up-to-date: enum34 in /opt/psa/var/modules/letsencrypt/venv.awDqz/lib/python2.7/site-packages (from cryptography)
Requirement already up-to-date: ipaddress in /opt/psa/var/modules/letsencrypt/venv.awDqz/lib/python2.7/site-packages (from cryptography)
Collecting cffi>=1.4.1 (from cryptography)
Using cached cffi-1.5.2.tar.gz
Requirement already up-to-date: pycparser in /opt/psa/var/modules/letsencrypt/venv.awDqz/lib/python2.7/site-packages (from cffi>=1.4.1->cryptography)
Installing collected packages: cffi, cryptography
Found existing installation: cffi 1.3.0
Uninstalling cffi-1.3.0:
Successfully uninstalled cffi-1.3.0
Running setup.py install for cffi … error
Complete output from command /usr/local/psa/var/modules/letsencrypt/venv.awDqz/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-build-dTp3ZJ/cffi/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-Ihy25V-record/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/psa/var/modules/letsencrypt/venv.awDqz/include/site/python2.7/cffi:
running install
running build
running build_py
creating build
creating build/lib.linux-i686-2.7
creating build/lib.linux-i686-2.7/cffi
copying cffi/backend_ctypes.py -> build/lib.linux-i686-2.7/cffi
copying cffi/model.py -> build/lib.linux-i686-2.7/cffi
copying cffi/gc_weakref.py -> build/lib.linux-i686-2.7/cffi
copying cffi/lock.py -> build/lib.linux-i686-2.7/cffi
copying cffi/cffi_opcode.py -> build/lib.linux-i686-2.7/cffi
copying cffi/commontypes.py -> build/lib.linux-i686-2.7/cffi
copying cffi/setuptools_ext.py -> build/lib.linux-i686-2.7/cffi
copying cffi/api.py -> build/lib.linux-i686-2.7/cffi
copying cffi/cparser.py -> build/lib.linux-i686-2.7/cffi
copying cffi/verifier.py -> build/lib.linux-i686-2.7/cffi
copying cffi/ffiplatform.py -> build/lib.linux-i686-2.7/cffi
copying cffi/vengine_cpy.py -> build/lib.linux-i686-2.7/cffi
copying cffi/vengine_gen.py -> build/lib.linux-i686-2.7/cffi
copying cffi/recompiler.py -> build/lib.linux-i686-2.7/cffi
copying cffi/init.py -> build/lib.linux-i686-2.7/cffi
copying cffi/_cffi_include.h -> build/lib.linux-i686-2.7/cffi
copying cffi/parse_c_type.h -> build/lib.linux-i686-2.7/cffi
copying cffi/_embedding.h -> build/lib.linux-i686-2.7/cffi
running build_ext
building ‘_cffi_backend’ extension
creating build/temp.linux-i686-2.7
creating build/temp.linux-i686-2.7/c
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -DUSE__THREAD -I/usr/include/python2.7 -c c/_cffi_backend.c -o build/temp.linux-i686-2.7/c/_cffi_backend.o
c/_cffi_backend.c:2:20: fatal error: Python.h: Datei oder Verzeichnis nicht gefunden
compilation terminated.
error: command ‘gcc’ failed with exit status 1

----------------------------------------

Rolling back uninstall of cffi
Command “/usr/local/psa/var/modules/letsencrypt/venv.awDqz/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-build-dTp3ZJ/cffi/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-Ihy25V-record/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/psa/var/modules/letsencrypt/venv.awDqz/include/site/python2.7/cffi” failed with error code 1 in /tmp/pip-build-dTp3ZJ/cffi/

Got this Error with you Fix


Plugin for plesk not working received the following error
#8

get the same error as Sn0x


#9

i found out: for debian and ubuntu try this before:

sudo apt-get install build-essential libssl-dev libffi-dev python-dev


#10

Works!! Nice thanks @all for you Support.


#11

It works ! Thanks to @Lyve and @yakuza2611 !


#12

You’re welcome :slight_smile:

I already had a development environment set up so I didn’t know about the compiler dependencies, good that yakuza found out :slight_smile:


#13

Thanks @Lyve and @yakuza2611,

However, I get the same error as Sn0x.

sudo apt-get install build-essential libssl-dev libffi-dev python-dev

didn’t work either (apt-get not found), so I tried the same command with yum:

sudo yum install build-essential libssl-dev libffi-dev python-dev

It does something (I’m sorry, I am very new to all this command line thingy), but it fails. I added some translations to the result:

Geladen plugins: fastestmirror
base | 3.6 kB 00:00:00
extras | 3.4 kB 00:00:00
plesk-letsencrypt | 2.9 kB 00:00:00
plesk-letsencrypt-tp | 2.9 kB 00:00:00
plesk-php-5.6 | 2.9 kB 00:00:00
updates | 3.4 kB 00:00:00
Loading mirror speeds from cached hostfile
Geen pakket build-essential beschikbaar. (no packet xxx available)
Geen pakket libssl-dev beschikbaar.
Geen pakket libffi-dev beschikbaar.
Geen pakket python-dev beschikbaar.
Fout: Niets te doen (error: nothing to do)

I think the problem is that apt-get uses different sources than yum, is that correct?
Also, does anyone know how to get around this problem to install Let’s Encrypt correctly?


#14

What operating system are you using ?

apt-get is normally used by debian based sysems ( debian, ubuntu etc)
yum is used by CentOS and related systems.

The topic title is about Debian 7.9 - however your system uses yum rather than apt-get I’m guessinng that your operating system isn’t Debian 7.9


#15

You are right. Shame on me I didn’t read the title that good, I got here by Googling the error.

I’m running CentOS 7 (64bit).


#16

I can’t split this topic - so potentially starting a new topic - for the correct OS maybe useful. Although hopefully one of the LE staff ( @jsha ) may well split this off into a new topic

What specific error are you getting (the errors installing certain “apt” packages is because you are using yum, and those aren’t the correct package names in centos) I’m not sure what packages you really need though without knowing what error you are trying to overcome.


#17

I installed Let’s Encrypt via Plesk’s extension manager. The install was succesful.
When I go to the LE extension and click on a domain to install the SSL certificate, it shows me the same error as in the first post of this topic:

Fout: Het installeren van het Let’s Encrypt SSL-certificaat is mislukt: Failed letsencrypt execution: Traceback (most recent call last):
File “/usr/local/psa/var/modules/letsencrypt/venv/bin/letsencrypt”, line 11, in <module>
sys.exit(main())
File “/usr/local/psa/var/modules/letsencrypt/venv.YVabb/lib/python2.7/site-packages/letsencrypt/cli.py”, line 1950, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/local/psa/var/modules/letsencrypt/venv.YVabb/lib/python2.7/site-packages/letsencrypt/plugins/disco.py”, line 168, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/local/psa/var/modules/letsencrypt/venv.YVabb/lib/python2.7/site-packages/letsencrypt/plugins/disco.py”, line 31, in init
self.plugin_cls = entry_point.load()
File “/usr/local/psa/var/modules/letsencrypt/venv.YVabb/lib/python2.7/site-packages/pkg_resources/init.py”, line 2201, in load
self.require(*args, **kwargs)
File “/usr/local/psa/var/modules/letsencrypt/venv.YVabb/lib/python2.7/site-packages/pkg_resources/init.py”, line 2218, in require
items = working_set.resolve(reqs, env, installer)
File “/usr/local/psa/var/modules/letsencrypt/venv.YVabb/lib/python2.7/site-packages/pkg_resources/init.py”, line 835, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (cryptography 1.1 (/usr/local/psa/var/modules/letsencrypt/venv.YVabb/lib/python2.7/site-packages), Requirement.parse(‘cryptography>=1.3’), set([‘PyOpenSSL’]))

Edit: I solved the problem running the following commands:

sudo yum install gcc libffi-devel python-devel openssl-devel

pip install cryptography
pip install --upgrade pip

cd /usr/local/psa/var/modules/letsencrypt/venv/bin
./pip install --upgrade cryptography

Right now, adding a certificate in Plesk works.


#19

Wow, thank you so much! This completely worked, bookmarking for the next bazillion servers I need to do this to. Going to


#20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.