Error when I try to renew my certificate


#1

Here is the error what should I do?I’m on parallel plesk 12.5

Error: Let’s Encrypt SSL certificate installation failed: Failed letsencrypt execution: Traceback (most recent call last):
File “/opt/psa/var/modules/letsencrypt/venv/bin/letsencrypt”, line 11, in <module>
sys.exit(main())
File “/usr/local/psa/var/modules/letsencrypt/venv.LcVsb/local/lib/python2.7/site-packages/letsencrypt/cli.py”, line 1950, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/local/psa/var/modules/letsencrypt/venv.LcVsb/local/lib/python2.7/site-packages/letsencrypt/plugins/disco.py”, line 168, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/local/psa/var/modules/letsencrypt/venv.LcVsb/local/lib/python2.7/site-packages/letsencrypt/plugins/disco.py”, line 31, in init
self.plugin_cls = entry_point.load()
File “/usr/local/psa/var/modules/letsencrypt/venv.LcVsb/local/lib/python2.7/site-packages/pkg_resources/init.py”, line 2201, in load
self.require(*args, **kwargs)
File “/usr/local/psa/var/modules/letsencrypt/venv.LcVsb/local/lib/python2.7/site-packages/pkg_resources/init.py”, line 2218, in require
items = working_set.resolve(reqs, env, installer)
File “/usr/local/psa/var/modules/letsencrypt/venv.LcVsb/local/lib/python2.7/site-packages/pkg_resources/init.py”, line 835, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (cryptography 1.1 (/opt/psa/var/modules/letsencrypt/venv.LcVsb/lib/python2.7/site-packages), Requirement.parse(‘cryptography>=1.3’), set([‘PyOpenSSL’]))


#2

I’m on FreeBSD, but I had an almost identical error. I needed to upgrade my python libraries, specifically my python cryptography libraries. At the time however, those updated libraries hadn’t been made available in ports, so I needed to downgrade to the previous client version.

Downgrading the client may not be practical for you (I have no experience with Plesk), but I think the issue is python. For me, it was py-cryptography (or something, I’m going from memory). I was running version 1.02 and the client needed version 1.3. You appear to running 1.1 and need 1.3. That’s what you’re error is telling you.

Can you try upgrading python and it’s dependant libraries?


#3

I have updated it but problem is still there same as before
Successfully installed cryptography idna pyasn1 six enum34 ipaddress cffi pycparser
Cleaning up…

I have updated it but prob is there maybe I should restart apache or something … :unamused:


#4

Ok solved the problem for all others with same problem here is the solution maybe it was before I don’t know

sudo apt-get install build-essential libssl-dev libffi-dev python-dev
source /usr/local/psa/var/modules/letsencrypt/venv.xxxxx/bin/activate
pip install --upgrade cffi
pip install --upgrade cryptography

After that you can renew ur certificate.

@DarkSteve thanks for help.


#5

real timesaver, thank you