Plugin for plesk not working received the following error


#1

I have installed the letsencrypt plugun for plesk control pane and am received the following error:

Traceback (most recent call last):
File “/usr/local/psa/var/modules/letsencrypt/venv/bin/certbot”, line 11, in
sys.exit(main())
File “/usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/lib/python2.7/site-packages/certbot/main.py”, line 700, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 174, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 33, in init
self.plugin_cls = entry_point.load()
File “/usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/lib/python2.7/site-packages/pkg_resources/init.py”, line 2280, in load
self.require(*args, **kwargs)
File “/usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/lib/python2.7/site-packages/pkg_resources/init.py”, line 2297, in require
items = working_set.resolve(reqs, env, installer)
File “/usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/lib/python2.7/site-packages/pkg_resources/init.py”, line 858, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (cryptography 1.3.1 (/usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/lib/python2.7/site-packages), Requirement.parse(‘cryptography>=1.3.4’), set([‘PyOpenSSL’]))

I have tried avery remedy I could find online with no success. Please help.


#2

I have tried the solutions listed here Plesk 12.5 [Debian 7.9] Error by create a SSL and none work. The final solution fails when I perform the /pip install --upgrade cryptography. I get errors and it doesn’t complete. The error I se is:

error: command ‘gcc’ failed with exit status 1


Failed building wheel for cryptography
Running setup.py clean for cryptography
Failed to build cryptography
Installing collected packages: cffi, cryptography
Found existing installation: cffi 1.5.2
Uninstalling cffi-1.5.2:
Successfully uninstalled cffi-1.5.2
Found existing installation: cryptography 1.3.1
Uninstalling cryptography-1.3.1:
Successfully uninstalled cryptography-1.3.1
Running setup.py install for cryptography … error
Complete output from command /usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-build-kqimzt/cryptography/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-iN67yf-record/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/psa/var/modules/letsencrypt/venv.W9Q9i/include/site/python2.7/cryptography:


#3

Plesk 12.5.30, CentOS 6.8, Python 2.6.6


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.