Permission Denied

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot install --cert-name

It produced this output:
The following error was encountered: [Errno 13] Permission denied: '/var/log/letsencrypt/.certbot.lock'
Either run as root, or set --config-dir, --work-dir, and --logs-dir to writeable paths.

My web server is (include version):

The operating system my web server runs on is (include version): apache

My hosting provider, if applicable, is: I don't know

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.22.0

certbot install --cert-name ...

Maybe try adding sudo in front of that command?

1 Like

I tried running it with sudo cerbot install --cert-name

it gives me this error:
Certbot could not find a VirtualHost for in the Apache configuration. Please create a VirtualHost with a ServerName matching and try again.

That speaks volumes.

Start with:
apachectl -t -D DUMP_VHOSTS

certbot certificates

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.