Ssh certbot set fails


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: itsfoodbiz.com

I ran this command: $ sudo certbot certonly --webroot -w /var/www/itsfoodbiz -d itsfoodbiz.com -d www.itsfoodbiz.com -d charladraper.com -d www.charladraper.com 0 0,12 * * * python -c ‘import random; import time; time.sleep(random.random() * 3600)’ && certbot renew

It produced this output: error not recognized

My web server is (include version): Linux

The operating system my web server runs on is (include version): Apahe 2.2.22

My hosting provider, if applicable, is: media temple

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Why? Those are two completely separate things–the first (through the www.charladraper.com) is the command to obtain your cert (presuming those are your four domain names), while the remainder of that line is a crontab entry.


#3

You might also have much better luck with

sudo certbot --apache

instead of the certonly command (for several reasons).


#4

I’m just following the instructions as best I can


#5

I tried that:

The following error was encountered:

[Errno 13] Permission denied: ‘/var/log/letsencrypt/.certbot.lock’

Either run as root, or set --config-dir, --work-dir, and --logs-dir to writeable paths.


#6

You got that error when running sudo certbot --apache, not certbot --apache?


#7

Which instructions would that be? https://certbot.eff.org/?


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.